Foros del Web » Creando para Internet » Flash y Actionscript »

necesito ayuda con actionscript

Estas en el tema de necesito ayuda con actionscript en el foro de Flash y Actionscript en Foros del Web. Estoy empezando con esto del actionscript. Uno de los ejercicios q estoy haciendo consiste en un objeto q se mueve x el escenario de flash ...
  #1 (permalink)  
Antiguo 26/06/2005, 14:25
 
Fecha de Ingreso: junio-2005
Mensajes: 6
Antigüedad: 12 años, 5 meses
Puntos: 0
necesito ayuda con actionscript

Estoy empezando con esto del actionscript. Uno de los ejercicios q estoy haciendo consiste en un objeto q se mueve x el escenario de flash hasta desaparecer, para volver a aparecer x el lado contrario.
En el ejemplo viene el siguiente codigo:
fotograma 1:
clip1._x++;
if (clip1._x>425){
clip1._x=-30;
}
fotograma 2:
gotoAndPlay(1);

he hecho el ejercicio tal y como lo describen, con el codigo copiado punto a punto........el ejemplo funciona xo el mio no se mueve :(.
Necesito una ayudita q m via volve loca. Gracias.
  #2 (permalink)  
Antiguo 26/06/2005, 14:56
Avatar de RobiBaggio
Colaborador
 
Fecha de Ingreso: enero-2005
Ubicación: Mind
Mensajes: 13.554
Antigüedad: 12 años, 11 meses
Puntos: 150
Ya tienes un MC llamado "clip1" verdad????

Si no, tienes que llamar al ese objeto que se mueve como clip1 que es a lo que hace referencia el código.

Saludos
  #3 (permalink)  
Antiguo 26/06/2005, 15:59
 
Fecha de Ingreso: junio-2005
Mensajes: 6
Antigüedad: 12 años, 5 meses
Puntos: 0
Si.Tengo el clip1 creadoxo cuando lo pruebo no se mueve......el ejercicio es para actionscript 1.0.. podria ser q lo hago en 2.0??? y si es asi, como lo cambio???
Gracias x tu ayuda ;).
  #4 (permalink)  
Antiguo 26/06/2005, 16:10
Avatar de stock  
Fecha de Ingreso: junio-2004
Ubicación: Monterrey NL
Mensajes: 2.390
Antigüedad: 13 años, 5 meses
Puntos: 53
prueba hacer esto:

Código PHP:
this.onEnterFrame = function():Void{
  
clip1._x++;
  if (
clip1._x>425){
    
clip1._x=-30;
  }

pones eso en un frame, instancias el MC como clip1 y ya!! debe funcionar

have fun
  #5 (permalink)  
Antiguo 27/06/2005, 13:29
 
Fecha de Ingreso: junio-2005
Mensajes: 6
Antigüedad: 12 años, 5 meses
Puntos: 0
Perdon, ayer me acoste en seguida.... tanto calentar las neuronas.... ya se sabe..jajajaja
Pero weno, sirvio de algo xq esta tarde m di cuenta de mi error-despiste...... le di nombre al simbolo en vez de al clip.. (q verwenza) Soy novata y aprendiendo x mi cuenta :S
Weno pos na, q muchas gracias y haasta pronto, xq me temo q no va ser la unica vez q m veais x aki.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:57.