Foros del Web » Creando para Internet » Flash y Actionscript »

New sound("meduelelacabeza.mp3")

Estas en el tema de New sound("meduelelacabeza.mp3") en el foro de Flash y Actionscript en Foros del Web. Hola: Ya no se que hecer con el new sound(). El problema es este: Estoy usando varios sonidos en una introduccion que, todos ellos forman ...
  #1 (permalink)  
Antiguo 29/11/2002, 06:54
 
Fecha de Ingreso: diciembre-2001
Ubicación: Olavarria - Buenos Aires
Mensajes: 295
Antigüedad: 16 años
Puntos: 1
New sound("meduelelacabeza.mp3")

Hola:
Ya no se que hecer con el new sound().
El problema es este:
Estoy usando varios sonidos en una introduccion que, todos ellos forman una musica completa, pero, cuando voy a la biblioteca y selecciono Vinculacion>exportar a action script, automaticamente se selecciona una casilla que dice algo como "exportar al primer fotograma".
Si la deselecciono, no se ejecuta el sonido y si la selecciono todos los sonidos van a parar al frame 0, esto es, antes de que empieze la precarga esta cargando todos los sonidos, y de esta manera no me sirve. Todo esto es con FLASH MX (era lo mismo con el 5).
¿Se entiende?.
Por favor les estare agradecido si pueden ayudarme.
Como siempre, gracias por adelantado.

STARLANCER
  #2 (permalink)  
Antiguo 29/11/2002, 07:31
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Perdoname, pero me podrias explicar mejor, ¿que es lo que necesitas??

:cantar: salu2 :cantar:
  #3 (permalink)  
Antiguo 30/11/2002, 11:50
 
Fecha de Ingreso: diciembre-2001
Ubicación: Olavarria - Buenos Aires
Mensajes: 295
Antigüedad: 16 años
Puntos: 1
Simple:
Quiero usar sonidos con New Sound(), pero tengo el problema de que usando el sonido de esta manera tarda mucho en iniciar la precarga, ¿ahora si?

STARLANCER
  #4 (permalink)  
Antiguo 30/11/2002, 12:07
Avatar de Abdiel  
Fecha de Ingreso: febrero-2002
Ubicación: Panamá
Mensajes: 126
Antigüedad: 15 años, 10 meses
Puntos: 1
Hola,
la solucion a tu problema es muy simple... solo debes de-seleccionar la casilla de "exportar al primer fotograma" y luego debes introducir una instancia de tu sonido en cualquier frame de tu pelicula, ya que de no hacerlo el .swf sera exportado sin los sonidos, ya que flash no exporta los sonidos si estos son llamados por ActionScript desde la libreria, a menos que se "exporten al primer fotograma". Puedes darle una ojeada a la Ayuda en "Propiedades de Vinculación" esta todo explicado...

Yo tuve ese mismo problemilla, pero lo unico que hice fue colocar una instancia de mi sonido en un frame cualquiera y luego en "edicion de sonido" le baje el Volumen a "0"para que no se escuchara. Con eso problema resuelto, flash incluye tu Sound dentro del .swf...

Suerte.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:29.