Foros del Web » Creando para Internet » Flash y Actionscript »

no consigo pasar las variables...

Estas en el tema de no consigo pasar las variables... en el foro de Flash y Actionscript en Foros del Web. Hola estimados colegas. Quisiera saber si me pueden dar una mano con este problemilla. Tengo una película que carga un swf en un movieclip a ...
  #1 (permalink)  
Antiguo 15/03/2005, 22:59
 
Fecha de Ingreso: diciembre-2002
Mensajes: 17
Antigüedad: 15 años
Puntos: 0
Pregunta no consigo pasar las variables...

Hola estimados colegas.
Quisiera saber si me pueden dar una mano con este problemilla.

Tengo una película que carga un swf en un movieclip a través de un moviecliploader y el método loadClip.
Este swf cargado contiene varios campos de ingreso de texto y una textarea (se trata del típico formulario de contacto)
tengo nombre_txt email_txt y comentarios_txt
al hacer click en un botón y tras una validación simple utilizo un
Código:
LoadVariablesNum(www.lindaflor.com.ar/mail.php, 0, "POST");
El archivo para enviar el mail en php es una cosa así:
Código PHP:
<?php

$mensaje 
"Nombre: " $nombre_txt ."\n\n""Mail: " $email_txt "\n\n" "Comentario: " $comentarios_txt;
$asunto="Mensaje enviado desde www.lindaflor.com.ar";
mail("[email protected]",$asunto,$mensaje"From: <$email_txt>\nX-Mailer: PHP/" phpversion());

?>
El problema es que cuando chequeo el mail llega en blanco, he revisado el nivel de las variables desde la película madre (la que carga este swf con el formulario) y todas están en el level0
También probé hacer http://www.lindaflor.com.ar/mail.php...xt=otracosamas
y el mail llega bien.
Ya se me acabaron las ideas...
Me darían una mano por favor?

Gracias.
__________________
NO HAY VERDAD, SOLO PERCEPCIÓN.
  #2 (permalink)  
Antiguo 16/03/2005, 02:54
pr0
 
Fecha de Ingreso: marzo-2004
Mensajes: 687
Antigüedad: 13 años, 8 meses
Puntos: 28
Cita:
LoadVariablesNum(www.lindaflor.com.ar/mail.php, 0, "POST");
Como bien remarco arriba, estas CARGANDO variables (load) desde mail.php.
lo correcto sería usar sendAndLoad("www.lindaflor.com.ar/mail.php", 0, "POST");

Saludos
  #3 (permalink)  
Antiguo 16/03/2005, 15:12
 
Fecha de Ingreso: diciembre-2002
Mensajes: 17
Antigüedad: 15 años
Puntos: 0
ya mismo lo pruebo, gracias
__________________
NO HAY VERDAD, SOLO PERCEPCIÓN.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:46.