Foros del Web » Creando para Internet » Flash y Actionscript »

No me ejecuta algunos comandos

Estas en el tema de No me ejecuta algunos comandos en el foro de Flash y Actionscript en Foros del Web. Hola de nuevo. He metido una serie de instrucciones en la pelicula pero no me las ejecuta cuando reproduzco la peli. fscommand("flashstudio.makefolder", "\"c:\pelicula\""); xLoc = ...
  #1 (permalink)  
Antiguo 18/12/2003, 03:11
 
Fecha de Ingreso: diciembre-2003
Mensajes: 2
Antigüedad: 14 años
Puntos: 0
Pregunta No me ejecuta algunos comandos

Hola de nuevo.

He metido una serie de instrucciones en la pelicula pero no me las ejecuta cuando reproduzco la peli.

fscommand("flashstudio.makefolder", "\"c:\pelicula\"");


xLoc = "0";
yLoc = "0";
ancho = _root.resx;
alto = _root.resy;
saveTo = "c:\ssnapshot.bmp";
fscommand("flashstudio.savebmp","xLoc,yLoc,ancho,a lto,saveTo");

Esta pelicula se creo con flash 5, y posteriormente la he retocado con flash Mx 2004, no se puede estar la ahi el problema.
  #2 (permalink)  
Antiguo 18/12/2003, 08:07
Avatar de el_leon  
Fecha de Ingreso: diciembre-2003
Ubicación: Buenos Aires, Argentina
Mensajes: 182
Antigüedad: 14 años
Puntos: 0
hola jrtejedor, el problema es simple:

tu código no es 100% ActionScript de Flash. Hay algunos comandos...
Código:
fscommand("flashstudio.savebmp","xLoc,yLoc,ancho,alto,saveTo");
por ejemplo, que corresponden a un software de terceros que compila swf y los convierte en .exe con características avanzadas.

por ende si no tienes el Flash Studio Pro (disponible en www.multidmedia.com ) para compilar luego el swf, esas acciones no se ejecutarán.

saludos

el_leon
[email protected]
_________________________
la web la hacemos entre todos
__________________
el_leon
[email protected]
____________________________
la web la hacemos entre todos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:51.