Foros del Web » Creando para Internet » Flash y Actionscript »

No ejecuta mi php

Estas en el tema de No ejecuta mi php en el foro de Flash y Actionscript en Foros del Web. Hola espero alguien me pueda ayudar, estoy utilizando flash mx 2004 y lo que me pasa es lo siguente publico mi pelicula en un servidor ...
  #1 (permalink)  
Antiguo 24/04/2007, 18:28
 
Fecha de Ingreso: enero-2003
Ubicación: Hacer deporte
Mensajes: 120
Antigüedad: 14 años, 11 meses
Puntos: 0
No ejecuta mi php

Hola espero alguien me pueda ayudar, estoy utilizando flash mx 2004 y lo que me pasa es lo siguente

publico mi pelicula en un servidor y en mi pelicula ejecuto el siguiente codigo

function enviod(xmen,xtel) {
c1 = new LoadVars();
c1.onLoad = insmen;
function insmen() {
xins = this.ins;
if (substring(xins,1,1)=="0") {
getURL("javascript:alert('El Mensaje ha sido enviado .... Gracias por utilizar nuestro Servicio')" );
}
else {
getURL("javascript:alert('No hay coneccion al Servidor consulta al Administrador')" );
}
}
c1.load("http://10.16.2.68/~interlotus/altmen.php?men="+xmen+"&tel="+xtel);
}

y no logro que se ejecute mi php en el otro servidor, mi pelicula esta en el 10.16.2.76 y el php esta en el 10.16.2.68

gracias de antemano
  #2 (permalink)  
Antiguo 24/04/2007, 18:35
 
Fecha de Ingreso: septiembre-2006
Mensajes: 1.193
Antigüedad: 11 años, 2 meses
Puntos: 30
Re: No ejecuta mi php

Código:
function enviod(xmen,xtel) {
c1 = new LoadVars();
c1.onLoad = insmen;
function insmen() {
xins = this.ins;
if (substring(xins,1,1)=="0") {
getURL("javascript:alert('El Mensaje ha sido enviado .... Gracias por utilizar nuestro Servicio')" );
}
else {
getURL("javascript:alert('No hay coneccion al Servidor consulta al Administrador')" );
}
}
c1.load("http://10.16.2.68/~interlotus/altmen.php?men="+xmen+"&tel="+xtel);
}
hasta donde se substring solo permite dos parametros no tres como pones tu.
lo que me gustaria saber es que es ins?
  #3 (permalink)  
Antiguo 24/04/2007, 18:39
Avatar de kalvinman  
Fecha de Ingreso: octubre-2006
Ubicación: Bogota Colombia
Mensajes: 849
Antigüedad: 11 años, 2 meses
Puntos: 22
Re: No ejecuta mi php

Imagino que debe hacer referencia a una instancia. ????
Pero deberian ser mas claros. xD
  #4 (permalink)  
Antiguo 25/04/2007, 08:38
 
Fecha de Ingreso: enero-2003
Ubicación: Hacer deporte
Mensajes: 120
Antigüedad: 14 años, 11 meses
Puntos: 0
Re: No ejecuta mi php

la variable this.ins es un valor que me regresa el php a flash con el cual pregunto si ejecuto el php, con respecto al paso de parametros pasan todos los que les quieras mandar lo he hecho y no he tenido ningun problema.

Este problema es por la seguridad que trae flash con respecto a los dominios, lo que se hace es poner un archivo xml dandole permiso al servidor de donde tengo mi pelicula de flash a ejecutar el mi php en otro servidor y en la flash se adiciona antes de ejecutar el loadvars.

en flash antes de utilizar el loadvars se pone la siguiente instruccion:

System.security.loadPolicyFile("http://10.16.2.68/~interlotus/mixml.xml");

y en le servidor 10.16.2.68 mixml.xml seria asi

<cross-domain-policy>
<allow-access-from domain="10.16.2.68" />
</cross-domain-policy>

Espero que alguien le pueda servir

atte.
Vik.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:54.