Foros del Web » Creando para Internet » Flash y Actionscript »

no entiendo porque no anda!

Estas en el tema de no entiendo porque no anda! en el foro de Flash y Actionscript en Foros del Web. hola amigos! les cuento tengo una animación de 5 frames. En el 5to frame tengo una imagen (algo sencillo) y en el frame 1 tengo ...
  #1 (permalink)  
Antiguo 19/12/2006, 18:05
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
no entiendo porque no anda!

hola amigos!

les cuento tengo una animación de 5 frames. En el 5to frame tengo una imagen (algo sencillo) y en el frame 1 tengo un preload, con el siguiente código:

Código:
onClipEvent (enterFrame) {
	loading = getBytesLoaded();
	total = getBytesTotal();
	percent -= (percent-((loading/total)*100))*.25;
	per = int(percent);
	percentage = per+"%";
	loadBar._xscale = per;
	if (percent>99) {
		_parent.gotoAndStop(2);
	}
}
la cuestión es que al probar la movie el preload no hace nada, raro ya que este mismo preload lo utilice en varias webs y nunca me trajo problemas.....¿alguna idea?

Gracias de antemano
DX
  #2 (permalink)  
Antiguo 19/12/2006, 18:10
Avatar de roc2107
ɹopɐɹǝpoɯ
 
Fecha de Ingreso: febrero-2003
Ubicación: León Guanajuato
Mensajes: 4.834
Antigüedad: 14 años, 9 meses
Puntos: 109
Re: no entiendo porque no anda!

No será por esto: _parent.gotoAndStop(2); se detiene en el fotograma 2 y tu dices que tienes una imagen en el 5. Será por eso???

Saludos.
__________________
Blog de Diseño Gráfico roc21.com || Exámenes

El secreto de la creatividad es saber esconder tus fuentes.
  #3 (permalink)  
Antiguo 19/12/2006, 18:10
Avatar de DarkskullDA  
Fecha de Ingreso: julio-2006
Mensajes: 698
Antigüedad: 11 años, 5 meses
Puntos: 13
Re: no entiendo porque no anda!

lo primero es asegurarte de q no l oestas provabdo en local..
en caso de q no te funcione..
revisate este link..
http://muelalab.com/blog/?p=32
suerte! ^^
__________________
Curso Desarrollo De Aplicaciones IFrame Para Facebook Conoce la Graph Api, Javascript/PHP SDK, Dialogos, Pestañas, entre otros.
  #4 (permalink)  
Antiguo 19/12/2006, 18:13
Avatar de Turdo  
Fecha de Ingreso: julio-2005
Ubicación: .:Guadalajara:.
Mensajes: 398
Antigüedad: 12 años, 4 meses
Puntos: 23
Re: no entiendo porque no anda!

Hola, actualizaste tu flash? o cambiaste de version? ya ves con eso de que algunos script dejan de funcionar de tal o cual modo ya me ha pasado, aqui te dejo la manera en que lo hago en flash8:

Cita:
stop();
this.onEnterFrame = function() {
carga = Math.floor((getBytesLoaded()/getBytesTotal())*100);
porcentaje = carga;
porcentaje._x = brr._x + brr._width;
if (carga == 100) {
_root.play();
delete this.onEnterFrame;
}
};
el brr es una barra!!!
  #5 (permalink)  
Antiguo 19/12/2006, 18:19
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Re: no entiendo porque no anda!

que despistado estoy ROC!!!!! cuando tés razon, tenés razon

Turdo mil gracias por la actualización del script!!!! Y gracias a todos por la rápida respuesta!!!!!!

GRACIAS!!!!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:20.