Foros del Web » Creando para Internet » Flash y Actionscript »

No funciona el codigo al cargar externamente

Estas en el tema de No funciona el codigo al cargar externamente en el foro de Flash y Actionscript en Foros del Web. Hola, tengo un swf llamado "juego.swf" con dos clips de pelicula i actionscript en cada uno de ellos. Desde otro swf cargo "juego.swf", pero una ...
  #1 (permalink)  
Antiguo 11/01/2005, 11:06
 
Fecha de Ingreso: marzo-2004
Mensajes: 44
Antigüedad: 13 años, 9 meses
Puntos: 0
Exclamación No funciona el codigo al cargar externamente

Hola, tengo un swf llamado "juego.swf" con dos clips de pelicula i actionscript en cada uno de ellos. Desde otro swf cargo "juego.swf", pero una vez cargada la película, el codigo de "juego.swf" no funciona, no hace nada, cuando antes de cargarlo externamente funciona perfectamanete. No creo que sea importante pero en "juego.swf" utilizo hiTest entre los dos clips de pelicula.

Espero haverme explicado lo suficietemente bien,

Gracias.
  #2 (permalink)  
Antiguo 11/01/2005, 12:05
Avatar de TMeister
Crazy Coder
 
Fecha de Ingreso: enero-2002
Ubicación: En la Oficina
Mensajes: 2.880
Antigüedad: 15 años, 11 meses
Puntos: 193
Asegurate de usar rutas relativas en el Codigo si haces referencia a _root desde juego.swf es muy posible que falle...

usa _parent, this, para las rutas
  #3 (permalink)  
Antiguo 11/01/2005, 12:23
Avatar de goc00  
Fecha de Ingreso: enero-2002
Ubicación: 000's DiMensiOn
Mensajes: 979
Antigüedad: 15 años, 11 meses
Puntos: 3
Saludos...

Exactamente como dice TMeister, es un problema de rutas. Lo más probable es que estés ocupando rutas absolutas (_root). Deberías utilizar rutas relativas como bien dice TMeister... _parent, this
__________________
GOC00 CominG soOn v2.0
CyA! & GooD LuCK...
  #4 (permalink)  
Antiguo 12/01/2005, 06:01
 
Fecha de Ingreso: marzo-2004
Mensajes: 44
Antigüedad: 13 años, 9 meses
Puntos: 0
Gracias a los dos, era ese problema, tengo la mala costumbre de poner siempre las rutas con _root i luego tengo este tipo de problema al cargar externamanete.

Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:20.