Foros del Web » Creando para Internet » Flash y Actionscript »

No me funciona en Firefox

Estas en el tema de No me funciona en Firefox en el foro de Flash y Actionscript en Foros del Web. Hola a todos, Estoy intentando añadir unas animaciones a mi web, y tengo esto: Código: <object classid="clsid:166B1BCA-3F9C-11CF-8075-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/director/sw.cab#version=8,0,0,0"> <param name=src value="animaciones/animacion1.dcr"> <!--[if !IE]> <--> <object ...
  #1 (permalink)  
Antiguo 02/06/2007, 05:59
 
Fecha de Ingreso: febrero-2007
Mensajes: 244
Antigüedad: 10 años, 9 meses
Puntos: 0
No me funciona en Firefox

Hola a todos,

Estoy intentando añadir unas animaciones a mi web, y tengo esto:

Código:
<object classid="clsid:166B1BCA-3F9C-11CF-8075-444553540000"		codebase="http://download.macromedia.com/pub/shockwave/cabs/director/sw.cab#version=8,0,0,0">
<param name=src value="animaciones/animacion1.dcr">
<!--[if !IE]> <-->
<object data="animaciones/animacion1.dcr" type="application/x-director">
<param name="pluginurl" value="http://www.macromedia.com/shockwave/download/">
FAIL (the browser should render some flash content, not this).
</object>
<!-->
<[endif]-->
</object>
Y el problema es que en IExplorer se me ve bien, pero en Firefox no se me ve nada, sólo se escucha....

¿Qué me puede estar pasando?

Gracias.
  #2 (permalink)  
Antiguo 02/06/2007, 09:02
 
Fecha de Ingreso: septiembre-2006
Mensajes: 1.193
Antigüedad: 11 años, 2 meses
Puntos: 30
Re: No me funciona en Firefox

te falta la etiqueta embed dentro de object


<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="1024" height="768" id="Untitled-6" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="allowFullScreen" value="false" />
<param name="movie" value="peli.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#000000" /> <embed src="peli.swf" quality="high" bgcolor="#000000" width="1024" height="768" name="peli" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>

en flash puedes crear el html del swf file->public settings
  #3 (permalink)  
Antiguo 03/06/2007, 14:18
Avatar de rod524  
Fecha de Ingreso: agosto-2004
Mensajes: 517
Antigüedad: 13 años, 4 meses
Puntos: 0
Re: No me funciona en Firefox

Según el código estás tratando de visualizar un archivo de director, no de flash.

Hay que revisar que se tenga instalado el ShockWave Player en FireFox.

En caso que no se tenga instalado el shockwave player, el código intenta buscar un contenido en Flash, el cual no has indicado, así que supongo que el archivo que te interesa es de director.

si eso te ha funcionado en IExplorer, Instala ShockWave Player para reproducir archivos de director en FireFox, ese ha de ser el problema, cada navegador instala sus plug-ins y controles ActiveX por separado.

Saludos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:15.