Foros del Web » Creando para Internet » Flash y Actionscript »

no me funciona la precarga

Estas en el tema de no me funciona la precarga en el foro de Flash y Actionscript en Foros del Web. quiero hacer una precarga, dondde se inceçremente elp valor de 0% a 100% conjuntamente con esto quiero que aparezcan imagenes por cada valor... ya vi ...
  #1 (permalink)  
Antiguo 04/12/2003, 11:08
 
Fecha de Ingreso: enero-2003
Ubicación: Santiago
Mensajes: 301
Antigüedad: 14 años, 10 meses
Puntos: 1
no me funciona la precarga

quiero hacer una precarga, dondde se inceçremente elp valor de 0% a 100% conjuntamente con esto quiero que aparezcan imagenes por cada valor...

ya vi el del deposito de flash y no me funciono....

por favor..
__________________
Cristian...
  #2 (permalink)  
Antiguo 04/12/2003, 13:10
 
Fecha de Ingreso: diciembre-2003
Mensajes: 12
Antigüedad: 14 años
Puntos: 0
Buenas.

Prueba algo como esto, mas o menos

porcentaje = int((getBytesLoaded()/getBytesTotal())*100);
barra._width = (borde._width*porcentaje)/100;
cargados = int(getBytesLoaded()/1024);
total = int(getBytesTotal()/1024);
if (cargados == total) {
gotoAndPlay("scene 2", 1);
} else {
gotoAndPlay(1);
}

En la Escena uno pones lo de antes y tres textfield que seran las variables porcentaje,cargados y total.

Luego puedes poner un clip (p. ej. la típica barra que crece cuando va cargando) y le llamas barra.

Cuando acabe de cargar en este ejemplo iras a la scene2 fotograma 1

Ya me contaras si te va.

Un saludo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:50.