Foros del Web » Creando para Internet » Flash y Actionscript »

no me funciona el unloadMovie

Estas en el tema de no me funciona el unloadMovie en el foro de Flash y Actionscript en Foros del Web. Cargo un swf en mc vacio. Cuando hago on(press) en otro movie clip quiero que se descargue el swf. Pongo on (press) { unloadMovie("seccion5.swf"); } ...
  #1 (permalink)  
Antiguo 08/05/2007, 11:22
Avatar de PedroRodas  
Fecha de Ingreso: noviembre-2005
Ubicación: Cádiz
Mensajes: 393
Antigüedad: 12 años
Puntos: 0
no me funciona el unloadMovie

Cargo un swf en mc vacio. Cuando hago on(press) en otro movie clip quiero que se descargue el swf.

Pongo on (press)
{
unloadMovie("seccion5.swf");
}
Tampoco me funciona con
unloadMovie("_root.seccion5.swf");

unloadMovie("_root.cargador.seccion5.swf");

Que puede estar fallando?

Gracias
  #2 (permalink)  
Antiguo 08/05/2007, 11:33
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: no me funciona el unloadMovie

Hola PedroRodas:
Para descargar una película que está cargada dentro de un MC_vacío, por ejemplo con nombre de instancia: contenedor.
El código debe ser así:
on(press){
contenedor.unloadMovie();
}
Para que la descarga se realice automáticamente, simplemente carga todas las películas en el mismo MC_vacío.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 08/05/2007, 15:48
Avatar de PedroRodas  
Fecha de Ingreso: noviembre-2005
Ubicación: Cádiz
Mensajes: 393
Antigüedad: 12 años
Puntos: 0
Re: no me funciona el unloadMovie

muchas gracias, eso era!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:55.