Foros del Web » Creando para Internet » Flash y Actionscript »

no me funcona los botones dentro del mc

Estas en el tema de no me funcona los botones dentro del mc en el foro de Flash y Actionscript en Foros del Web. hola a todos! estoy con un problema que busque en el foro pero no encontre la solucion. lo que estoy haciendo es la famosa tira ...
  #1 (permalink)  
Antiguo 28/12/2005, 09:55
 
Fecha de Ingreso: agosto-2005
Ubicación: argentina
Mensajes: 28
Antigüedad: 12 años, 3 meses
Puntos: 0
no me funcona los botones dentro del mc

hola a todos! estoy con un problema que busque en el foro pero no encontre la solucion.
lo que estoy haciendo es la famosa tira de imagenes que se mueve (cuando paso el mouse,) pero que adentro en vez de una imagen tiene muchos botones, estos a su vez llaman a:
on (release) {
loadMovie("colgante1.swf", "medio");
}

el tema es que hice lo que bandit explico que es lo de hacer un mc con las fotos y lo de la programacion :
// posición slider
slider._x += (2-_xmouse)*0.02;
slider_r._x = slider._x+slider._width;
slider_l._x = slider._x-slider._width;
if (slider._x>100+slider._width*0.5) {
slider._name = "temp";
slider_l._name = "slider";
temp._name = "slider_l";
}
if (slider._x<0-slider._width*0.5) {
slider._name = "temp";
slider_r._name = "slider";
temp._name = "slider_r";
}

todo esto super funciona! lo que no me funcionan son los botones y no se porqueeee! alguien me puede explicar?? mil gracias
saludos, espero haber sido clara
  #2 (permalink)  
Antiguo 28/12/2005, 10:38
Avatar de alexander_sp  
Fecha de Ingreso: febrero-2004
Ubicación: Barcelona
Mensajes: 694
Antigüedad: 13 años, 9 meses
Puntos: 4
Cuando no me sale algo.... de ese estilo jejeje
pruevo con
_root.
_parent.

no se si será eso. Chao
  #3 (permalink)  
Antiguo 28/12/2005, 10:55
Avatar de lucasiramos  
Fecha de Ingreso: agosto-2004
Ubicación: Santa Rosa, La Pampa, Argentina
Mensajes: 1.484
Antigüedad: 13 años, 4 meses
Puntos: 13
Claro, como dice Alexander, fijate a ver si es:
on (release) {
loadMovie("colgante1.swf", "_root.medio");
}

O usando la ruta absoluta o relativa.
Saludos. Lucas
__________________
No sign...
  #4 (permalink)  
Antiguo 28/12/2005, 11:43
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola coky_mar:
En el escenario tienes que ponerle un MC vacío con nombre de instancia: contenedor y en el botón:
on(press){
_root.contenedor.loadMovie("nombre.jpg");
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 28/12/2005, 16:12
 
Fecha de Ingreso: agosto-2005
Ubicación: argentina
Mensajes: 28
Antigüedad: 12 años, 3 meses
Puntos: 0
mil gracias!!!

muchisimas gracias por su ayuda, me funciono a la perfeccion las 2 opciones!

saludos
Felices Fiestas!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:10.