Foros del Web » Creando para Internet » Flash y Actionscript »

No llegan las variables a un loadMovie

Estas en el tema de No llegan las variables a un loadMovie en el foro de Flash y Actionscript en Foros del Web. Buenas, tengo un problemilla. El caso es que tengo un formulario flash con PHP que funciona a la perfección. Flash envia las variables al php ...
  #1 (permalink)  
Antiguo 13/02/2007, 17:45
 
Fecha de Ingreso: diciembre-2002
Ubicación: Madrid
Mensajes: 378
Antigüedad: 15 años
Puntos: 11
No llegan las variables a un loadMovie

Buenas, tengo un problemilla.

El caso es que tengo un formulario flash con PHP que funciona a la perfección. Flash envia las variables al php y el php le devuelve un mensaje de confirmación del mensaje enviado.

Hasta aquí todo bien.


El problema viene cuando cargo el formulario en mi SWF principal, a través de un loadMovie. Ahí es cuando ya la respuesta del php no llega, se debe quedar en le camino.

¿ Alguna sabe como solucionarlo ?

Cargo el formulario

Código:
carga_mc.loadMovie("form_contacto.swf");
Aquí es donde el formulario, una vez enviado

Cita:
action = "send";
loadVariablesNum (mailform, 0, "POST");
gotoAndStop ("espera");
espera a recibir la variable del php

Código:
loadVariablesNum(respuesta.php, 0);
answer = "Un momento ...";
stop();

Y esta es la función del php que devuelve la variable $send_answer; que no llega.

Código:
$sendresult = "El mensaje fue enviado \n Nos comunicaremos con usted lo antes posible. Gracias.";
$send_answer = "answer=";
$send_answer .= rawurlencode($sendresult);
echo "$send_answer";

Un saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:11.