Foros del Web » Creando para Internet » Flash y Actionscript »

No navega entre escenas

Estas en el tema de No navega entre escenas en el foro de Flash y Actionscript en Foros del Web. [FONT=Arial]Recién terminé un catalogo, pero no me están obedeciendo las acciones que pusse a los botones. Puse el script según lo hacía desde flash 2003 ...
  #1 (permalink)  
Antiguo 11/12/2004, 12:40
 
Fecha de Ingreso: diciembre-2004
Mensajes: 1
Antigüedad: 13 años
Puntos: 0
No navega entre escenas

[FONT=Arial]Recién terminé un catalogo, pero no me están obedeciendo las acciones que pusse a los botones. Puse el script según lo hacía desde flash 2003 y mx, vi que ahora con el 2004 te pide los parametros aparte y se los ponía (seguramente mal) nosé en qué está mal. Después intenté con el tutorial, pero tampoco responden bien estos son los scripts que puse siguiendo ,las instrucciones del tutorial:

//detiene la cabeza de reproducción en el frame 1
stop();

laboratorio_btn.onRelease = function (){
gotoAndStop("laboratorio", 1);
};
stopAllSounds();

servicios_btn.onRelease = function (){
gotoAndStop("servicios", 1);
};
stopAllSounds();

si_btn.onRelease = function (){
gotoAndStop("si", 1);
};
stopAllSounds();

contacto_btn.onRelease = function (){
gotoAndStop("contacto", 1);
};

stopAllSounds();


El proyecto tiene un inicio con menu y 4 escenas más, los botones estan en todas las escenas y tienen esos scripts, pero una vez probadza la pelicula, no navega entre escenas.
Ojalá me pudieran ayudar, muchas gracias

saludos
Tahto
  #2 (permalink)  
Antiguo 11/12/2004, 13:04
Avatar de Mahalo  
Fecha de Ingreso: julio-2004
Ubicación: Mallorca (Illes Balears)
Mensajes: 1.121
Antigüedad: 13 años, 4 meses
Puntos: 12
Hola.
Prueba a etiquetar los fotogramas. Por ejemplo, llama el primer fotograma de la escena "laboratorio" de la misma manera, y deja el código igual pero sin el 1:
gotoAndPlay ("laboratorio");
Yo siempre uso este sistema y no da problemas. Un saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:07.