Foros del Web » Creando para Internet » Flash y Actionscript »

Ocultar botones mientras se reproduce swf externo

Estas en el tema de Ocultar botones mientras se reproduce swf externo en el foro de Flash y Actionscript en Foros del Web. Hola, necesito ayuda al respecto de como ocultar los botones de la interface que cargan unos . swf externos , mientras estos se reproducen, en ...
  #1 (permalink)  
Antiguo 23/12/2005, 09:18
 
Fecha de Ingreso: abril-2005
Mensajes: 9
Antigüedad: 12 años, 8 meses
Puntos: 0
Ocultar botones mientras se reproduce swf externo

Hola, necesito ayuda al respecto de como ocultar los botones de la interface que cargan unos .swf externos, mientras estos se reproducen, en un lugar de la propia interface, justo encima de esos botones, quedan ocultos por la pelicula que se carga, pero LOS BOTONES ESTAN SELECCIONABLEs, yo quiero que no lo esten mientras se reproduce el .swf i que vuelvan a estarlo quando este se termine (los cierra y los abre el usuarioi mediante un boton)
Alguna simple forma de hacerlo?
Mil gracias
Holaswr
  #2 (permalink)  
Antiguo 23/12/2005, 09:33
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola holaswr:
Colócale un nombre de instancia a tus botones, por ejemplo: btn, btn y en el botón que carga la película adiciona éste código: btn.enabled = false; y en el botón cerrar de la película: btn.enabled = true;

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 23/12/2005, 10:13
 
Fecha de Ingreso: abril-2005
Mensajes: 9
Antigüedad: 12 años, 8 meses
Puntos: 0
Gracias, pero resulta que el boton que abre el .swf externo esta en la peli principal y el boton que cierra en .swf externo que cargo esta en ese .swf externo, he probado lo que me sugieres y una vez que se reproduce queda oculto para "todos los siempres", creo que como el boton de cierre esta en la peli secundaria, falta algo en el codigo no? entonces...
  #4 (permalink)  
Antiguo 23/12/2005, 10:20
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
_root.btn.enabled = true;
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 23/12/2005, 10:44
 
Fecha de Ingreso: abril-2005
Mensajes: 9
Antigüedad: 12 años, 8 meses
Puntos: 0
Bandit, el lluna_btn.enabled = false; en la peli pral funciona perfecto, pero se queda false, pongo el _root.lluna_btn.enabled = true; en el boton que cierra la pelicula secundaria, en el ultimo fotograma, en el primero, y continua igual de false, puede ser porque esa pelicula no la cargo en un mc vacio en la pelicula principal, sino que la abro directament en la interface?
Repito mil gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:05.