Foros del Web » Creando para Internet » Flash y Actionscript »

on/onClip Event

Estas en el tema de on/onClip Event en el foro de Flash y Actionscript en Foros del Web. Lo primero de todo deciros que mis nociones de flash son muy básicas. El caso es que la web de mi empresa tenían que cambiar ...
  #1 (permalink)  
Antiguo 17/07/2008, 06:35
 
Fecha de Ingreso: julio-2008
Mensajes: 3
Antigüedad: 9 años, 4 meses
Puntos: 0
on/onClip Event

Lo primero de todo deciros que mis nociones de flash son muy básicas.

El caso es que la web de mi empresa tenían que cambiar un par de cosas y no tenían el documento en fla sólo el swf. He utilizado un descompilador para obtenerlo y esta todo perfecto salvo un error que me da que pertenece a la barra de progreso de la carga del flash. Dice:

La declaración debe aparecer dentro del controlador on/onClipEvent

Os pongo el código del origen:

//Componente)
{
conversion = 1;
direction = "right";
label = "LOADING %3%% ";
labelPlacement = "bottom";
mode = "event";
source = "";
visible = true;
minHeight = 0;
minWidth = 0;
}

Muchas gracias
  #2 (permalink)  
Antiguo 17/07/2008, 09:30
 
Fecha de Ingreso: abril-2008
Ubicación: Montevideo - Uruguay
Mensajes: 156
Antigüedad: 9 años, 7 meses
Puntos: 5
Respuesta: on/onClip Event

Hi !

Prueba de esta manera:
Código:
onClipEvent (load) {
    conversion = 1;
    direction = "right";
    label = "LOADING %3%% ";
    labelPlacement = "bottom";
    mode = "event";
    source = "";
    visible = true;
    minHeight = 0;
    minWidth = 0;
}
Espero te sea util!

-ByE-
__________________
--
Mi Portfolio Online! Visitalo!
--
  #3 (permalink)  
Antiguo 17/07/2008, 09:44
 
Fecha de Ingreso: julio-2008
Mensajes: 3
Antigüedad: 9 años, 4 meses
Puntos: 0
Respuesta: on/onClip Event

Vale ya no da error, pero la animación que se supone una barra de cargando en porcentaje no sale, se queda un cuadrado en blanco. Para poder ver la web tengo que presionar a mano boton derecho reproducir.

:(
  #4 (permalink)  
Antiguo 17/07/2008, 10:30
 
Fecha de Ingreso: abril-2008
Ubicación: Montevideo - Uruguay
Mensajes: 156
Antigüedad: 9 años, 7 meses
Puntos: 5
Respuesta: on/onClip Event

Hi !

Hay algo más de codigo que no hayas puesto? No sé me ocurre porque puede ser... Podrias hacer un .fla con la "barra de carga" solamente y pasarnoslo para poder ver el problema.

-ByE-
__________________
--
Mi Portfolio Online! Visitalo!
--
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:20.