Foros del Web » Creando para Internet » Flash y Actionscript »

paranoias...

Estas en el tema de paranoias... en el foro de Flash y Actionscript en Foros del Web. Estoy desquiciado.. y es que no lo entiendo es muy raro esto. Tengo un gotoAndPlay al que le digo que se vaya al frame X. ...
  #1 (permalink)  
Antiguo 23/02/2005, 02:00
 
Fecha de Ingreso: diciembre-2004
Mensajes: 278
Antigüedad: 13 años
Puntos: 0
paranoias...

Estoy desquiciado.. y es que no lo entiendo es muy raro esto.
Tengo un gotoAndPlay al que le digo que se vaya al frame X.
Bien, en este frame tengo un mvclip, el gotoAndPlay funciona.
Coloco otro mvclip que contiene una imagen importada en el frame X tambien;
el gotoAndPlay deja de funcionar y se reproduce la pelicula desde donde se encuentra el gotoAndPlay...
Elimino el ultimo mvclip insertado, y coloco otro que tambien contiene otra imagen (pero diferente) y vuelve a funcionar...
He abierto el Movieclip que da problemas i contiene solamente un frame con la imagen.. nada de actionscript.

He de decir que cosas como està no es la primera vez que me ocurren, hasta hace poco en una animación (bastante larga por cierto) me era imposible pasar de cierto frame a traves de un gotoAndPlay, cosa que me fustraba un huevo ya que a la hora de probar la pelicula era un horror llegar hasta donde yo quería.
Al final lo solucioné eliminando frames en blanco que habia en el inicio de la linea de tiempo de algun movieclip, pero esque en la que me encuentro ahora no hay ninguno en blanco al inicio!!!!
Además, el comportamiento del error es diferente también, en la animación anterior, digamos que si queria ir al frame 200, no pasaba del 100 i se reproducía desde éste. En canvio ahora no solo no encuentra el frame, sino que se reproduce desde donde está el gotoAndPlay como he dicho antes (igual es xq ahora voy por escenas, antes no).

Pero igualmente, es muy raro esto de que con una imagen sude del goto y con otras no...
A ver si me podeis hechar una mano, que estoy de estas paranoias del flash...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:44.