Foros del Web » Creando para Internet » Flash y Actionscript »

Pelicula muy pesada...

Estas en el tema de Pelicula muy pesada... en el foro de Flash y Actionscript en Foros del Web. Consulta: tengo una pelicula que contiene muchas imagenes. Pesa como unos 500 k pues hice un scrollpane donde las voy mostrando. El problema que me ...
  #1 (permalink)  
Antiguo 26/06/2004, 14:55
 
Fecha de Ingreso: diciembre-2003
Ubicación: Mi casa
Mensajes: 65
Antigüedad: 14 años
Puntos: 0
Pelicula muy pesada...

Consulta: tengo una pelicula que contiene muchas imagenes. Pesa como unos 500 k pues hice un scrollpane donde las voy mostrando. El problema que me surge es al cargar. La pelicula contiene dos escenas. En la primer escena hice un cargador que se fija si cargaron todos los frames y una vez hecho esto va al primer frame de la segunda escena que es donde se encuentra el scrollpane con las imagenes. El tema es que nunca se llega a ver el "loading" porque para flash el primer frame de toda la pelicula mide 500 k. No encuentro la manera de cambiar esto. Aparte no entiendo por que le asigna todo ese tamaño al primer frame si es que ahi se encuentra solamente el movieclip del "loading" y no deberia pasar al frame con las imagenes si todavia no cargo todo. Se ve que se fija todos los objetos que contiene la libreria y asume que el primer frame pesa todo eso...no entiendo como hacer.
Espero que me puedan ayudar con esto...
Muchas gracias...
  #2 (permalink)  
Antiguo 26/06/2004, 19:43
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola decabeza:
Te muestra 500 kb porque la película pesa así, la 2 escenas forman parte de la misma película, el código del loading verifica el peso de toda ella, antes del código de la precarga ponle un stop(); en el frame 1 de la escena 1.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 28/06/2004, 08:19
 
Fecha de Ingreso: diciembre-2003
Ubicación: Mi casa
Mensajes: 65
Antigüedad: 14 años
Puntos: 0
No hay caso..

Gracias Bandit por la ayuda. Pero no me ha funcionado. Te cuento que ya tenia un stop. La escena 1 contiene un mc con el loading al cual se le asigno el codigo que controla la carga. A su vez en esa escena en otra capa, al primer frame le di la accion de "Stop". Pero aun asi no me anda. Cuando pruebo la peli en flash y le doy "simulate download" observo que flash te va mostrando el porcentaje de carga entre otros datos y para el mientras no cargue esos 500 k , asume que la cantidad de frames cargados son 0 . Por eso es que no llega a ejecutar si quiera el "Stop".
Es algo que me esta quemando la cabeza!!
Gracias igual !

Por cierto: si quieren bajar el archivo .fla pueden hacerlo en este link : http://www.lariales.com.uy/bmw.zip

Última edición por decabeza; 28/06/2004 a las 08:24
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:04.