Foros del Web » Creando para Internet » Flash y Actionscript »

Por favor Ayudenme...

Estas en el tema de Por favor Ayudenme... en el foro de Flash y Actionscript en Foros del Web. Hola ojala alguien pueda ayudarme...hice un formulario en flash pero mi hosting solo corre CGI...ahora el formulario tiene las siguientes acciones en un keyframe... stop(); ...
  #1 (permalink)  
Antiguo 20/01/2004, 19:35
 
Fecha de Ingreso: enero-2004
Mensajes: 17
Antigüedad: 13 años, 10 meses
Puntos: 0
Por favor Ayudenme...

Hola ojala alguien pueda ayudarme...hice un formulario en flash pero mi hosting solo corre CGI...ahora el formulario tiene las siguientes acciones en un keyframe...
stop();
//
function borrar() {
nombre = "";
email = "";
asunto = "";
comentarios = "";
}
//
function enviar() {
enviar = new LoadVars();
enviar.nombre = nombre;
enviar.email = email;
enviar.asunto = asunto;
enviar.comentarios = comentarios;
enviar.onLoad = function(success) {
gotoAndStop(38);
};
enviar.sendAndLoad("http://www.ladireccion.com/cgi-local/formmail.pl", enviar, "POST");
}

Ahora en el boton Enviar estan estas acciones.....

on (press) {
enviar();
}


OK pues me sucede esto...lleno el formulario y lo envio y si me llega a la direccion de e-mail correspondiente que es la que esta en el CGI...pero me llega de esta manera....

Datos del usuario
_________________________________________
Nombre : _level0.instance30.nombre
Email : _level0.instance30.email
Asunto : _level0.instance30.asunto
Comentarios : _level0.instance30.comentarios

____Datos del servidor emisor del mensaje___


Entonces como veran no me llegan los textos que llene en el formulario el mail llega asi exactamente como lo puse...alguien podria decirme que falta ? por favor ...

Gracias de antemano.
Mariana.
  #2 (permalink)  
Antiguo 21/01/2004, 05:01
 
Fecha de Ingreso: octubre-2003
Ubicación: Granada
Mensajes: 481
Antigüedad: 14 años, 2 meses
Puntos: 1
es raro seguro q eso pq estas utilizando rutas absolutas..
bueno hazlo de manera manual ,supongo q utilizaras text box :
function enviar() {
enviar = new LoadVars();
enviar.nombre = nombre.text;
enviar.email = email.text;
enviar.asunto = asunto.text;
enviar.comentarios = comentarios.text;
enviar.onLoad = function(success) {
gotoAndStop(38);
};
enviar.sendAndLoad("http://www.ladireccion.com/cgi-local/formmail.pl", enviar, "POST");
}

de esta manera obligas a q te coja las rutas relativas...
pero mira a ver q tipo de rutas tienes
otra cosa.....
si ves q aun sigues con problemas manda las variables mediante get

http://www.ladireccion.com/cgi-local...t.............

ok??
un saludo
__________________
la duda es el principio del saber
  #3 (permalink)  
Antiguo 21/01/2004, 17:49
 
Fecha de Ingreso: enero-2004
Mensajes: 17
Antigüedad: 13 años, 10 meses
Puntos: 0
Saludos Cristian !!

Mil gracias ya funciono te agradezco muchisimo tu ayuda y tus atenciones

Ahora solo sucede una cosa...el boton borrar no funciona no se a que se debe ojala pudieras decirme que esta mal... las acciones del boton borrar estan asi...

on (press) {
borrar();
}

y no borra los campos no se por que

Y una ultima pregunta sabras como hacerle para que de alguna manera el formulario valide que los campos estan llenos ? y que salga algun mensaje que diga "llene los campos correctamente" ?
esto ya no es tan importante pero si se pudiera pues adelante si no dejalo...

si pudieras ayudarme te lo agradeceria muchisimo.


Gracias Cristian..un beso.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:09.