Foros del Web » Creando para Internet » Flash y Actionscript »

Por mas que lo intento no logro verlo....

Estas en el tema de Por mas que lo intento no logro verlo.... en el foro de Flash y Actionscript en Foros del Web. Bueno antes de nada, saludos a todos por el trabajo y las ayudas prestadas, llebo algun tiempo leyendo el foro y esta muy bien. Vereis ...
  #1 (permalink)  
Antiguo 05/06/2008, 10:20
 
Fecha de Ingreso: junio-2008
Mensajes: 14
Antigüedad: 9 años, 6 meses
Puntos: 0
Por mas que lo intento no logro verlo....

Bueno antes de nada, saludos a todos por el trabajo y las ayudas prestadas, llebo algun tiempo leyendo el foro y esta muy bien.

Vereis tengo una duda que seguro sera un tonteria pero por muchas vueltas que le doi no lo logro ver:


tengo una escena, y en esa escena un MC con todos los botones de la barra de navegacion dentro, luego tengo otro MC y dentro de ese tengo 3 frames con actionscript para crear un texto con efecto de maquina de escribir, y lo que quiero es que uno de esos botones de dentro del mc de la barra de navegacion, me cargue el mc con el texto.

Si pongo un boton dentro del mc del texto con un play (); al darle a ese boton arrancan las letras, pero si suprimo ese boton e intento hacer lo mismo con uno de los botones de la barra de navegacion no me carga, estoi algo perdido y ya no se que hacer.

deciros tb, dentro del mc del texto tengo, un texto dinamico en blanco con el nombre de estancia llamado str, para que el texto me lo visualice ai, y en los 3 frames que tengo con el codigo tengo lo siguiente:

1º frame:

myText = "el texto que quiero que salga";
mytext += "mas texto que quiero que salga";
myText += "\n\n\t\t\t\t\t by Craneos.";
c = 1;
stop ();

2º frame:


escribir();
function escribir() {
if (c<=myText.length) {
str.text = myText.substr(0, c);
c = c+1;
} else {
stop();
}
}


3º frame:

gotoAndPlay(2);


No se si con todo esto me he podido explicar con toda clariada de mi problema o si me dejara algo preguntenme y yo les resuelvo.

Muchas gracias de antes mano y un saludo.
  #2 (permalink)  
Antiguo 05/06/2008, 13:52
 
Fecha de Ingreso: junio-2008
Mensajes: 14
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: Por mas que lo intento no logro verlo....

Bueno son las 20:50 hora española y ando toda la tarde con esto, no encontre solucion alguna para hacer lo que busco o soy muy ciego y no logro encontrar lo que falla, pero por hoy lo dejo.

Un saludo.
  #3 (permalink)  
Antiguo 05/06/2008, 15:10
 
Fecha de Ingreso: abril-2008
Mensajes: 613
Antigüedad: 9 años, 8 meses
Puntos: 22
Respuesta: Por mas que lo intento no logro verlo....

Hola,
Tal vez sea un problema de jerarquía. Si tienes los botones en un MC y los textos en otro, lo normal es que puesieras un nombre de instancia al MC que contiene los textos y desde los botones hicieras referencia a él. Te pongo el ejemplo:

- el MC de textos le pones "instextos" como nombre de instancia.

En el boton tienes que poner:
on(press){
_parent.instextos.play();

Saludos
__________________
Compartir es vivir
www.programador-php.com
  #4 (permalink)  
Antiguo 05/06/2008, 15:55
 
Fecha de Ingreso: junio-2008
Mensajes: 14
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: Por mas que lo intento no logro verlo....

Pues mil gracias porque era eso en concreto, me solucionaste un dolor de cabeza que no lo puede ni imaginar.

Un saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:20.