Foros del Web » Creando para Internet » Flash y Actionscript »

Porblemas con botón

Estas en el tema de Porblemas con botón en el foro de Flash y Actionscript en Foros del Web. Tengo un menú con botones puestos en círculo de manera que en el centro queda un espacio en blanco. Al pasar por encima de un ...
  #1 (permalink)  
Antiguo 20/03/2004, 06:11
 
Fecha de Ingreso: marzo-2004
Mensajes: 44
Antigüedad: 13 años, 9 meses
Puntos: 0
Pregunta Porblemas con botón

Tengo un menú con botones puestos en círculo de manera que en el centro queda un espacio en blanco. Al pasar por encima de un botón quiero que me aparezca un texto en el centro. Esto lo ago con un simple actionscript que al pasar por encima del botón cargue el fotograma 2 en el que hay otra vez el menú con el texto dentro del circulo y al salir de encima del botón vuelve al fotograma 1 de manera que el fotograma desaparece. El problema esta en que al añadir el actionscript la el botón pierde calidad. Aquí les dejo la muestra i el .fla. Si me pudieran ayudar o decir otra manera mejor de hacer el efecto que deseo, se los agradecería mucho.

Gracias

http://www.ipmel.net/mkr/1.zip
  #2 (permalink)  
Antiguo 20/03/2004, 10:59
Avatar de PatomaS
Colaborador
 
Fecha de Ingreso: marzo-2004
Ubicación: En alguna otra parte
Mensajes: 4.656
Antigüedad: 13 años, 9 meses
Puntos: 63
Hola

Bueno, es bastante raro eso que mencionas...

Descargué el archivo que decías, pero el fla no se puede abrir, o al menos yo no lo pude abrir. Por otro lado, el .swf se ve bien...

tal vez si lo envias otra vez, o pones una dirección en la que podamos ver el antes y después...

SUerte

Felicidad
__________________
¡ hey, hou, hou, hey !
  #3 (permalink)  
Antiguo 20/03/2004, 13:52
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola Makron:
En primer lugar solamente a los botones "centre" y "nosaltres" le haz puesto en el frame "Reposo" y "Sobre" el alpha 50 y 100 y al resto solamente tienes el gráfico en el frame "Reposo" con alpha 100, por esa razón no ves el cambio de imagen cuando pones el mouse encima del botón.
En la línea principal en la capa 1 está bien los botones pero los textos que quieres que aparezca tienes que colocarlo en diferentes capas y frames, ejemplo: capa2 frame 2 "HOME", capa 3 frame 3 el otro texto y así sucesivamente.
Crea una capa para las acciones y en el frame 1 un Stop(); y allí en el botón "centre" coloca este 2 códigos:
on(rollOver){
gotoAndStop(2);
}
on(rollOut){
gotoAndPlay(1);
}

en el resto de botones repite los códigos solamente cambiando en el primer gotoAnStop el frame donde esté el siguiente texto.
En conclusión vas a tener 7 capas para todo.

Espero haberte sido de ayuda, cualquier duda avisa.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #4 (permalink)  
Antiguo 22/03/2004, 12:12
 
Fecha de Ingreso: marzo-2004
Mensajes: 44
Antigüedad: 13 años, 9 meses
Puntos: 0
Muchas gracias, si me sirve de ayuda pero la casa que es el único botón que tiene puesto el actionscript, si se fijan, al previsualizar la película se ve como cortada, cosa que en realidad no es así. No se si a ustedes se les ve mal, a lo mejor solo me pasa a mi, por favor ayúdenme.


Gracias
  #5 (permalink)  
Antiguo 22/03/2004, 21:33
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola Makron:

Espero que la explicación que te dí haya solucionado el problema que tenías.
El botón "casa" se visualiza sin problemas, debe ser problema de tu proyector.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:08.