Foros del Web » Creando para Internet » Flash y Actionscript »

porque no funciona la lupa?

Estas en el tema de porque no funciona la lupa? en el foro de Flash y Actionscript en Foros del Web. que tal foristas, resulta y acontece que estoy haciendo mi sitio web. resulta que en una de las secciones le estoy colocando una lupa pero ...
  #1 (permalink)  
Antiguo 20/09/2005, 09:47
Avatar de ceaped  
Fecha de Ingreso: febrero-2004
Mensajes: 2.078
Antigüedad: 13 años, 10 meses
Puntos: 9
Pregunta porque no funciona la lupa?

que tal foristas, resulta y acontece que estoy haciendo mi sitio web.
resulta que en una de las secciones le estoy colocando una lupa pero no me funciona................dicha lupa esta en un swf............la lupa la pongo en otra pelicula y me funciona.............que estara pasando?.
este es el codigo de la lupa:

1-el MC lupa:

onClipEvent (load) {
x_escala = 100;
y_escala = 100;
aumento = 2;
aceleracion = 3;
_root.texto.aceleracion = aceleracion;
function escala_texto(sc) {
_root.texto.x_escala = sc*100;
_root.texto.y_escala = sc*100;
}
}
onClipEvent (mouseMove) {
_x = _root._xmouse;
_y = _root._ymouse;
if (!zoom) {
}
}
onClipEvent (mouseDown) {
if (hitTest(_root._xmouse, _root._ymouse, false)) {
if (aumento == 2) {
escala_texto(aumento);
aumento = 1;
} else {
escala_texto(aumento);
aumento = 2;
}
}
}
onClipEvent (enterFrame) {
autoescala(aceleracion);
}



2-el MC texto (nombre de instancia "texto"):

onClipEvent (load) {
x_escala = 100;
y_escala = 100;
yp = 0;
}
onClipEvent (enterFrame) {
_xscale = _xscale+((x_escala-_xscale)/aceleracion);
_yscale = _yscale+((y_escala-_yscale)/aceleracion);
}

como les decia lo pongo en otra pelicula y me funciona, lo pongo en el swf y no me funciona.

saludos
__________________
Diseñador Gráfico publicitario
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:48.