Foros del Web » Creando para Internet » Flash y Actionscript »

porque la precarga del swf no se ve?

Estas en el tema de porque la precarga del swf no se ve? en el foro de Flash y Actionscript en Foros del Web. Hola. Hice un sitio web y resulta que las preacargas de los swf no se ven en prograso solo el final y al momento muestra ...
  #1 (permalink)  
Antiguo 31/03/2005, 13:19
Avatar de ceaped  
Fecha de Ingreso: febrero-2004
Mensajes: 2.078
Antigüedad: 13 años, 10 meses
Puntos: 9
Pregunta porque la precarga del swf no se ve?

Hola.
Hice un sitio web y resulta que las preacargas de los swf no se ven en prograso solo el final y al momento muestra el contenido del swf

pongo el codigo de la precarga a ver en que estoy fallando

onClipEvent (enterFrame) {
cargados = _root.getBytesLoaded();
totales = _root.getBytesTotal();
carga = int((cargados/totales)*100);
mover = carga;
porcentaje = mover+" "+"%";
this.gotoAndPlay(mover);
}


y dentro de la precarga

_root.carga.gotoAndPlay(1);
stop();


saludos
__________________
Diseñador Gráfico publicitario
  #2 (permalink)  
Antiguo 31/03/2005, 13:54
Avatar de junihh  
Fecha de Ingreso: febrero-2004
Ubicación: República Dominicana
Mensajes: 997
Antigüedad: 13 años, 10 meses
Puntos: 7
Yo lo haria asi:
Código:
stop();
onEnterFrame = function () {
	cargados = _root.getBytesLoaded();
	totales = _root.getBytesTotal();
	carga = Math.floor(cargados/totales*100);
	porcentaje = carga+" %";
	if (carga == 100) {
		gotoAndPlay(mover);
	}
};
Y entenderas que en el stage debe existir un campo con el nombre de variable "porcentaje". Eso es todo.

Otra cosa, no entiendo eso de la precarga. Si es que tienes una barra que muestra el porciento cargado, agregas lo siguiente despues de "porcentaje":

barra._xscale = carga

y debe haber un MC con el nombre de instancia "barra" en el stage.

Espero que esto te ayude.
__________________
JuniHH
- Mi blog
- Mi portafolio

Última edición por junihh; 31/03/2005 a las 14:00
  #3 (permalink)  
Antiguo 01/04/2005, 06:03
Avatar de ceaped  
Fecha de Ingreso: febrero-2004
Mensajes: 2.078
Antigüedad: 13 años, 10 meses
Puntos: 9
hola junihh voy a mirar el codigo que me pasaste y te cuento luego. Por el momento muchas gracias
__________________
Diseñador Gráfico publicitario
  #4 (permalink)  
Antiguo 04/04/2005, 07:42
Avatar de marcozeb  
Fecha de Ingreso: septiembre-2004
Mensajes: 10
Antigüedad: 13 años, 2 meses
Puntos: 0
k' tal, a mi me pasó eso en mis primeros pininos y te comento que eso pasa a veces cuando el loader, o los objetos que tenes en ese primer frame son demasiados Kb's osea muchas cosas o muy grandes, prueba quitando algunas o alivianando el peso, tu loader en el primer Frame no debe ser muy pesado prueba con uno que sea menor a 5kb
  #5 (permalink)  
Antiguo 04/04/2005, 11:18
Avatar de junihh  
Fecha de Ingreso: febrero-2004
Ubicación: República Dominicana
Mensajes: 997
Antigüedad: 13 años, 10 meses
Puntos: 7
Un frame que tenga una entrada con objetos que pesan 5KB es pesado... lo mejor es usar elementos vectores en el frame del loader, de forma que no lleguen a pesar mas de 400 bytes, si quieres que el loader se vea desde el principio.

Esto tomando en cuenta a los navegantes que tienen modem... que son la mayoria.
__________________
JuniHH
- Mi blog
- Mi portafolio
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:40.