Foros del Web » Creando para Internet » Flash y Actionscript »

Posición erronea

Estas en el tema de Posición erronea en el foro de Flash y Actionscript en Foros del Web. No he podido lograr que una movie me carge una película desde la parte superior izquierda hacia abajo, siempre lo hace desde el centro. Como ...
  #1 (permalink)  
Antiguo 25/11/2003, 13:31
Avatar de ztikma  
Fecha de Ingreso: diciembre-2001
Ubicación: Viña del Mar
Mensajes: 1.144
Antigüedad: 16 años
Puntos: 1
Posición erronea

No he podido lograr que una movie me carge una película desde la parte superior izquierda hacia abajo, siempre lo hace desde el centro. Como soluciono ésto ??

saludos
__________________
La Pana
  #2 (permalink)  
Antiguo 25/11/2003, 14:28
Avatar de siddharta  
Fecha de Ingreso: octubre-2003
Ubicación: siguiendo el sagrado dharma del flash
Mensajes: 294
Antigüedad: 14 años, 1 mes
Puntos: 0
Facil! lo que estas haciendo es cargar el movieclip por level, lo que debes hacer es cargarlo por target a una instancia de un movieclip vacio, el movieclip cargado se posicionara en la coodrenada x:0 y:0 del clip que lo recibe, entonces, solo pones el clip interno en donde desees, incluso le puedes dar propiedades ( movimiento, escala, alpha..etc) y el clip cargado estara sujeto a ellas.

suerte!
__________________
Probablemente estoy pagando una deuda karmica... pero no sabia que me cobraban con intereses.
------------------------------------------------
  #3 (permalink)  
Antiguo 25/11/2003, 14:55
Avatar de ztikma  
Fecha de Ingreso: diciembre-2001
Ubicación: Viña del Mar
Mensajes: 1.144
Antigüedad: 16 años
Puntos: 1
Eso hice lo cargué por target dentro de una movie clip pero me empieza a cargar desde el centro. No sé como hacer para que tome el borde superior izquierdo como coordenada x:0 y:0.

saludos
__________________
La Pana
  #4 (permalink)  
Antiguo 25/11/2003, 18:54
Avatar de siddharta  
Fecha de Ingreso: octubre-2003
Ubicación: siguiendo el sagrado dharma del flash
Mensajes: 294
Antigüedad: 14 años, 1 mes
Puntos: 0
el clip que recibe tiene que estar en X:0 y Y:0 y el "centro" del clip que cargas debe ser tambien X:0 y Y:0. para que quede claro te mando un zip con un fla y un swf para cargar, descomprimelos en la misma carpeta. En el fla dice como acomodarlo, veras que es muy simple.

http://www.15minutos.com/carga.zip
__________________
Probablemente estoy pagando una deuda karmica... pero no sabia que me cobraban con intereses.
------------------------------------------------
  #5 (permalink)  
Antiguo 26/11/2003, 06:46
Avatar de ztikma  
Fecha de Ingreso: diciembre-2001
Ubicación: Viña del Mar
Mensajes: 1.144
Antigüedad: 16 años
Puntos: 1
Tuve que modificar la movie para que el vertice empezara desde ese "centro", no pude mover el centro por si solo.
Pero ahora funciona perfectamente.

Muchas gracias
__________________
La Pana
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:59.