Foros del Web » Creando para Internet » Flash y Actionscript »

Precarga no funciona con el audio

Estas en el tema de Precarga no funciona con el audio en el foro de Flash y Actionscript en Foros del Web. Buenos días. Hice una Web la cual cargo desde la película principal por medio de loadMovie("swf", centro). La precarga para los swf me funciona bién; ...
  #1 (permalink)  
Antiguo 18/09/2007, 08:10
Avatar de ceaped  
Fecha de Ingreso: febrero-2004
Mensajes: 2.078
Antigüedad: 13 años, 10 meses
Puntos: 9
Pregunta Precarga no funciona con el audio

Buenos días.
Hice una Web la cual cargo desde la película principal por medio de loadMovie("swf", centro).

La precarga para los swf me funciona bién; sólo no me funciona cuando en un swf pongo el sonido, la precarga no se ve su progreso (descubri que si en esta película sonido pongo porejemplo imagenes si se ve el progreso de la precarga).

Este es el código que empleo en la precarga:

onClipEvent (enterFrame) {
with (this._parent) {
aumentar = Math.round(getBytesLoaded()/getBytesTotal()*100);
_root.barra_mc._xscale = aumentar;
_root.barra_mc2._xscale = aumentar;
porcentaje_txt.text = aumentar+"%";
if (aumentar == 100) {
this._parent.gotoAndPlay(_currentframe+1);
}
}
}

Gracias por su ayuda
__________________
Diseñador Gráfico publicitario
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:04.