Foros del Web » Creando para Internet » Flash y Actionscript »

Pregunta sobre algo carga MC "Error de carga"

Estas en el tema de Pregunta sobre algo carga MC "Error de carga" en el foro de Flash y Actionscript en Foros del Web. Tema, tengo un Btn que me envía a otro frame y el código es el siguiente: on (release) { nextFrame(); //crea movie createEmptyMovieClip("lines", 2); lines._x ...
  #1 (permalink)  
Antiguo 29/11/2005, 17:18
Avatar de shamuray  
Fecha de Ingreso: agosto-2004
Ubicación: Capital Federal, Argentina
Mensajes: 142
Antigüedad: 13 años, 4 meses
Puntos: 0
Pregunta sobre algo carga MC "Error de carga"

Tema, tengo un Btn que me envía a otro frame y el código es el siguiente:

on (release)
{
nextFrame();
//crea movie
createEmptyMovieClip("lines", 2);
lines._x = 0;
lines.loadMovie("menu.swf");
}

Y desde el menú cargo en un clip de película "carga" un panel.swf y desde el menu.swf
Quiero cargar desde algunos de los link un submenu dragueable en el clip de película "carga1" y tengo el siguiente código en esos link, pero no funsiona bien

on (release)
{
//crea movie
_root.carga1.loadMovie("submenu.swf");
unloadMovie(carga);
}

y ya probé de la siguiente manera sin buen puerto de llegada...

on (release)
{
//crea movie
_root.carga1.loadMovie("submenu.swf");
_root.unloadMovie(carga);
}

Por lo tanto la idea es descargar el panel y cargar en otro clip de película "carga1" el submenu.swf, así desde este puedo utilizar el clip "carga" para los paneles o imagenes etc

Tienen alguna solución

Gracias de antemano
"Salu2"
__________________
:pirata: •´¯¥¯•Ð€MØNiØ•´¯¥¯• :pirata:
  #2 (permalink)  
Antiguo 29/11/2005, 17:33
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola shamuray:
Si todos los MC vacíos están en el escenario principal debería funcionar sin problemas, a menos que lo tengas dentro de un MC o la tengas dentro del .swf cargado.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 29/11/2005, 17:53
Avatar de shamuray  
Fecha de Ingreso: agosto-2004
Ubicación: Capital Federal, Argentina
Mensajes: 142
Antigüedad: 13 años, 4 meses
Puntos: 0
No me funciona bien por que con este código en los link del menú para cargar el submenú y descargar el panel me descarga todo y no se ve nada...

on (release)
{
//crea movie
_root.carga1.loadMovie("submenu.swf");
//descarga movie
_root.unloadMovie(carga);
}

Y de esta manera solo carga el submenú pero no descarga el panel...

on (release)
{
//crea movie
_root.carga1.loadMovie("submenu.swf");
//descarga movie
unloadMovie(carga);
}
__________________
:pirata: •´¯¥¯•Ð€MØNiØ•´¯¥¯• :pirata:
  #4 (permalink)  
Antiguo 29/11/2005, 18:07
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Sin ver como lo estás haciendo es muy complicado darte la receta exacta.
Trata de subir tus archivos a un servidor para poderlos ver.

Espero heberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 30/11/2005, 06:34
Avatar de -=ArgoN=-  
Fecha de Ingreso: octubre-2005
Ubicación: Barcelona, España
Mensajes: 843
Antigüedad: 12 años, 1 mes
Puntos: 1
Cita:
Iniciado por shamuray
Código:
_root.unloadMovie("carga");
unloadMovie("carga");
* Prueba con esto.

ArgoN
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:48.