Foros del Web » Creando para Internet » Flash y Actionscript »

Preloader no funciona cuando es llamado por otro swf

Estas en el tema de Preloader no funciona cuando es llamado por otro swf en el foro de Flash y Actionscript en Foros del Web. Hola a todos, Estoy haciendo una pequeña galería de fotos para una sección de una web que estoy desarrollando ahora mismo. Lo he hecho de ...
  #1 (permalink)  
Antiguo 05/09/2006, 12:07
 
Fecha de Ingreso: mayo-2006
Mensajes: 64
Antigüedad: 11 años, 7 meses
Puntos: 0
Preloader no funciona cuando es llamado por otro swf

Hola a todos,
Estoy haciendo una pequeña galería de fotos para una sección de una web que estoy desarrollando ahora mismo.

Lo he hecho de la siguiente manera:

Un flash principal, con el menu. Al pinchar en cada sección del menu, se carga en un movieclip vacío (al que llamo ZONA, que uso para situar el flash nuevo cargado) la galería indicada.

El problema está en que al cargar ese nuevo flash sobre el principal, la precarga no funciona como debiera.
La precarga sí funciona perfectamente con el flash por separado.

Aquí pueden ver el flash, y como funciona mal el loader al pinchar en una galería (solo hay hechas algunas):
http://www.webplan.es/tenisweb/instalaciones.html

Y aquí pueden ver una galeria por separado, que como veis, funciona perfectamente:
http://www.webplan.es/tenisweb/pistasdetenis.swf

Un saludo y gracias!
__________________
webplan - Diseño y desarrollo de páginas webs.
Desde Andalucía - España
  #2 (permalink)  
Antiguo 05/09/2006, 16:46
Avatar de CREW  
Fecha de Ingreso: diciembre-2004
Ubicación: Mi Casa
Mensajes: 793
Antigüedad: 13 años
Puntos: 0
consulta los SWF que cargas....en tu pelicula principal, no muy pesados, ya que si no pesan nada la precarga es rapida por lo que no se logra apreciar...
__________________
_________________________________
Mario Contreras || Diseñador Gráfico + Web:Mi Blog
  #3 (permalink)  
Antiguo 05/09/2006, 19:34
 
Fecha de Ingreso: mayo-2006
Mensajes: 64
Antigüedad: 11 años, 7 meses
Puntos: 0
Ya probé haciéndolos mas pesados, pero definitivamente la precarga funciona fatal.
Creo que el problema está en que llamando a otro swf las precargas del que fue llamado no funcionan bien, y no se porqué ni como solucionarlo

Mira esta otra galeria, funciona perfectamente
http://www.webplan.es/tenisweb/cs_historia.html
__________________
webplan - Diseño y desarrollo de páginas webs.
Desde Andalucía - España
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:18.