Foros del Web » Creando para Internet » Flash y Actionscript »

La primera vez no me abre en la misma página...

Estas en el tema de La primera vez no me abre en la misma página... en el foro de Flash y Actionscript en Foros del Web. Hola, tengo un problema que no logro superar... ayuda!!, verán, tengo un menu en AS3 y los botones deben abrir las paginas en la paginaactual, ...
  #1 (permalink)  
Antiguo 08/09/2009, 09:32
 
Fecha de Ingreso: octubre-2008
Mensajes: 81
Antigüedad: 12 años, 4 meses
Puntos: 3
Pregunta La primera vez no me abre en la misma página...

Hola, tengo un problema que no logro superar... ayuda!!, verán, tengo un menu en AS3 y los botones deben abrir las paginas en la paginaactual, d siempre he sabido que self es para abrir en la misma pagina y blank en una nueva, pero, en mi menu, la primera vez que hago click en algun boton, me abre en otra ventana, pero lo mas extraño es que en esa otra ventana al dar click en los botones ya no me abre otras ventanas sino que ya en la misma. Debo decir que si doy de nuevo click en los botones de la primera ventana, las paginas se despliegan, pero en la segunda :S. El problema es tanto en Firefox como en el Explorer. Mi codigo es éste, que hago mal?:

btn3.addEventListener(MouseEvent.CLICK, tweenMyObjectClick3);
btn3.buttonMode = true;
btn3.useHandCursor = true;

function tweenMyObjectClick3(myEvent:MouseEvent){
var uRequest:URLRequest = new URLRequest("local.html");
navigateToURL(uRequest, 'self');
}
  #2 (permalink)  
Antiguo 08/09/2009, 10:24
Avatar de TMeister
Crazy Coder
 
Fecha de Ingreso: enero-2002
Ubicación: En la Oficina
Mensajes: 2.880
Antigüedad: 19 años, 1 mes
Puntos: 193
Respuesta: La primera vez no me abre en la misma página...

No uses self, no es necesario

navigateToURL(uRequest);

y listo el problema se va.
  #3 (permalink)  
Antiguo 08/09/2009, 10:56
 
Fecha de Ingreso: octubre-2008
Mensajes: 81
Antigüedad: 12 años, 4 meses
Puntos: 3
Respuesta: La primera vez no me abre en la misma página...

No funciona, eso ya lo habia hecho, para confirmar lo he vuelto a hacer y nada. Alguna otra sugerencia?
  #4 (permalink)  
Antiguo 08/09/2009, 12:59
 
Fecha de Ingreso: octubre-2008
Mensajes: 81
Antigüedad: 12 años, 4 meses
Puntos: 3
Respuesta: La primera vez no me abre en la misma página...

Solucionado, no es 'self' sino "_self", si lo dejo como dijiste TMeister, me lo toma como _blank, supongo ese es el valor por default. Gracias.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:23.