Foros del Web » Creando para Internet » Flash y Actionscript »

problea con formulario

Estas en el tema de problea con formulario en el foro de Flash y Actionscript en Foros del Web. sres. termine un formulario... pero tengo un problema, creoq ue chiquito... pero no lo puedo resolver... el formulario funciona correctamente... el unico problema que en ...
  #1 (permalink)  
Antiguo 17/11/2006, 07:31
Avatar de lbenz  
Fecha de Ingreso: marzo-2003
Ubicación: Haedo
Mensajes: 445
Antigüedad: 14 años, 8 meses
Puntos: 4
problea con formulario

sres. termine un formulario... pero tengo un problema, creoq ue chiquito... pero no lo puedo resolver...

el formulario funciona correctamente... el unico problema que en el textarea en donde se escribe el emnsaje lo tengo en single line, anda perfectamente, ahora cuando lo paso a multiline, porqeu lo necesito multiline... no me funciona mas... o sea, en estado me dice que el mensaje fue enviado, pero jamas llega... vuelvo a probar con single line y funciona.

L averdad que no se si el problema esta en AS o en el php, es por esoq ue les envio los codigos de ambos... esperoq ue me puedan ayudar..

Leo


Codigo AS

enviar = function () {
if (email_txt.text.length && nombre_txt.length && titulo_txt.length && mensaje_txt.length)
{if (email_txt.text.indexOf("@") != -1 && email_txt.text.indexOf(".") != -1) {
form_lv = new LoadVars();
form_lv.nombre = nombre_txt.text;
form_lv.mail = email_txt.text;
form_lv.mensaje = mensaje_txt.text;
form_lv.titulo = titulo_txt.text;
form_lv.sendAndLoad("send.php", form_lv, "POST");
mensaje_txt.text = "Enviando Mensaje..";
nombre_txt.text = "";
email_txt.text = "";
titulo_txt.text = "";
form_lv.onLoad = function() {trace("LLEGO");
if (this.estatus == "ok") {mensaje_txt.text = "Tu mensaje fue enviado...";
nombre_txt.text = "";
email_txt.text = "";
titulo_txt.text = "";}
else {
mensaje_txt.text = "Problemas con el servidor\nIntentalo de Nuevo";}};
} else {
email_txt.text = "Correo Invalido";}
} else {
email_txt.text = "Dato Necesario";
nombre_txt.text = "Dato Necesario";
titulo_txt.text = "Dato Necesario";
mensaje_txt.text = "Dato Necesario";}};
borrar = function ()
{ nombre_txt.text = "";
email_txt.text = "";
mensaje_txt.text = "";
titulo_txt.text = "";};
enviar_btn.onRelease = enviar;
borrar_btn.onRelease = borrar;


send.php

<?php
if(isset($_POST["nombre"]) && isset($_POST["titulo"]) && isset($_POST["mail"]) && isset($_POST["mensaje"]) ){
$fecha = date("D-M-y H:i");
$mymail = "[email protected]";
$subject = $_POST["titulo"]."\n\n";
$contenido = $_POST["nombre"]." Escribio :\n";
$contenido .= $_POST["mensaje"]."\n\n";
$contenido .= "el mensaje se escribio el ".$fecha;
$header = "From:".$_POST["mail"]."\nReply-To:".$_POST["mail"]."\n";
$header .= "X-Mailer:PHP/".phpversion()."\n";
$header .= "Mime-Version: 1.0\n";
$header .= "Content-Type: text/plain";
mail($mymail, $subject, utf8_decode($contenido) ,$header);
echo "&estatus=ok&";
}
?>


desde ya muchas gracias...
__________________
que fea firma que tenia... prefiero tener esto
  #2 (permalink)  
Antiguo 17/11/2006, 14:34
 
Fecha de Ingreso: septiembre-2006
Mensajes: 1.193
Antigüedad: 11 años, 2 meses
Puntos: 30
prueba ese mismo formulario corregido un poco

http://www.forosdelweb.com/f16/enviando-mail-no-sale-438466/
  #3 (permalink)  
Antiguo 17/11/2006, 15:22
Avatar de lbenz  
Fecha de Ingreso: marzo-2003
Ubicación: Haedo
Mensajes: 445
Antigüedad: 14 años, 8 meses
Puntos: 4
mi correo es [email protected]

por si me podes mandar archivos de formularios

asi yo pruebo esi el problema esta en el servidor o en que

muchas graciasss por la ayuda

saludos
__________________
que fea firma que tenia... prefiero tener esto
  #4 (permalink)  
Antiguo 18/11/2006, 13:23
 
Fecha de Ingreso: septiembre-2006
Mensajes: 1.193
Antigüedad: 11 años, 2 meses
Puntos: 30
en esta liga al final esta el codigo que corregi un poco
http://www.forosdelweb.com/showthread.php?t=438466
y en esta esta el fla solo corrige el codigo por el que puse.
http://www.maestrosdelweb.com/editorial/fflashphpform/
  #5 (permalink)  
Antiguo 18/11/2006, 16:33
Avatar de lbenz  
Fecha de Ingreso: marzo-2003
Ubicación: Haedo
Mensajes: 445
Antigüedad: 14 años, 8 meses
Puntos: 4
entiendo

ya probe cone so que me dijistes... el problema es que no es multiline, ese es mi problema
__________________
que fea firma que tenia... prefiero tener esto
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:02.