Foros del Web » Creando para Internet » Flash y Actionscript »

problema attachMovie dentro de mascara

Estas en el tema de problema attachMovie dentro de mascara en el foro de Flash y Actionscript en Foros del Web. Tengo una mascara un una capa llamada máscara en la cual he dibujado un rectangulo sólido. En otra capa llamada acciones he instanciado un mc ...
  #1 (permalink)  
Antiguo 11/06/2003, 10:19
 
Fecha de Ingreso: mayo-2003
Ubicación: sevilla
Mensajes: 51
Antigüedad: 14 años, 7 meses
Puntos: 0
problema attachMovie dentro de mascara

Tengo una mascara un una capa llamada máscara en la cual he dibujado un rectangulo sólido.
En otra capa llamada acciones he instanciado un mc con la ayuda de attachMovie de la siguiente forma:

_root.createEmptyMovieClip("intercambio",0);

_root.intercambio.attachMovie("2","segundo",0);
_root.intercambio._xscale = 450;
_root.intercambio._yscale = 450;
_root.intercambio._x = 550/2;
_root.intercambio._y = 346/2;

Pero el problema es que el rectangulo no enmascara a la instancia "segundo".

Que puede hacer???
En que capa se esta creando la instancia.

Por favor ayudarme.Que me echan del curroo.¡¡¡¡¡¡
  #2 (permalink)  
Antiguo 11/06/2003, 11:19
Avatar de TMeister
Crazy Coder
 
Fecha de Ingreso: enero-2002
Ubicación: En la Oficina
Mensajes: 2.880
Antigüedad: 15 años, 11 meses
Puntos: 193
Ya casi no se utiliza las mascaras por medio de Layer lo mejor es hacerlo desde AS.
Yo lo haria asi:

Pongo un Clip que sera el Enmascarado (fondo) despues atacho el Clip que sera la mascara y por ultimo le asigno la mascara por medio de setMask();

Código:
mask = attachMovie("mascara","m",2);
mask._x = 100;
mask._y  =100;
fondo.setMask(mask);
Ahora si quieres que la mascara sea Dragable:

Código:
mask = attachMovie("mascara","m",2);
mask._x = 100;
mask._y  =100;
mask.onPress = function (){
	this.startDrag();
	}
mask.onRelease = function(){
	stopDrag();
	}
fondo.setMask(mask);
Saludos!!
  #3 (permalink)  
Antiguo 11/06/2003, 12:15
 
Fecha de Ingreso: mayo-2003
Ubicación: sevilla
Mensajes: 51
Antigüedad: 14 años, 7 meses
Puntos: 0
De acuerdo

Muchas Gracias, voy a probar y ya te digo.
Un saludo.

Perfecto.
Eres un fenómeno.
Solución rápida y eficaz.
Oleeeeeeeeee.
  #4 (permalink)  
Antiguo 25/06/2003, 11:31
 
Fecha de Ingreso: mayo-2003
Ubicación: sevilla
Mensajes: 51
Antigüedad: 14 años, 7 meses
Puntos: 0
sigo teniendo problemas con setMask

Hola TMesister, Hace tiempo me solucionaste mi problema de forma espectacular y ahora tengo un problemilla con lo mismo.

Tengo una película con un solo fotograma, en el cual pongo la acción siguiente:

this.onLoad= function (){

_root.intercambio.setMask(_root.masca);
};

Y todo iba estupendamente, hasta que quise poner un preloader sencillo.

Cree una escena nueva delante de la que funcionaba y puse el preloader.Ahora resulta que no hace el setMask y no sé xq.

Sabes que puede ser??.
Contestame por favor que tengo que sacar este trabajo adelante.
Gracias de antemano.Un saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:33.