Foros del Web » Creando para Internet » Flash y Actionscript »

Problema botones y clips de película.

Estas en el tema de Problema botones y clips de película. en el foro de Flash y Actionscript en Foros del Web. Tengo un problemilla que no se como solucionar y es que me tiene un muy parado. Resulta que tengo un clip de película con una ...
  #1 (permalink)  
Antiguo 16/03/2009, 04:31
 
Fecha de Ingreso: marzo-2009
Mensajes: 3
Antigüedad: 8 años, 9 meses
Puntos: 0
Exclamación Problema botones y clips de película.

Tengo un problemilla que no se como solucionar y es que me tiene un muy parado.

Resulta que tengo un clip de película con una serie de botones, pues los botones no me cambien de estado cuando interactuo con ellos y no me hacen nada del codigo que les tengo asignados.

el problema ocurre cuando en la escena principal pongo lo siguiente:

//Muestra hola clip al pulsar sobre el clip de película
clip_inst.onPress = function(){
trace("hola clip");
}

//Muestra hola boton al pulsar sobre el botón.
clip_inst.btn.onPress = function() {
trace("hola boton");
};

************************************************** ************
La segunda función es la que no me hace nada

Muchas gracias de antemano.
  #2 (permalink)  
Antiguo 16/03/2009, 04:52
Avatar de golem44  
Fecha de Ingreso: enero-2009
Ubicación: barcelona
Mensajes: 483
Antigüedad: 8 años, 11 meses
Puntos: 22
Respuesta: Problema botones y clips de película.

No le pongas puntos en los nombres de instancia, pon guiones bajos y no pongas nombres tales como text, btn...

espero ayudarte, saludos
  #3 (permalink)  
Antiguo 16/03/2009, 05:20
 
Fecha de Ingreso: marzo-2009
Mensajes: 3
Antigüedad: 8 años, 9 meses
Puntos: 0
Respuesta: Problema botones y clips de película.

Indistintamente del nombre que le ponga a los clip o a los botones me ocurre.

si pongo

nombre_clip.onPress=function(){
//cualquier cosa
}....

ya no me deja interactuar con ningún botón de dicho clip de película

Yo agrego el clip de película con el botón a la escena principal y el código lo indico sobre ese mismo fotograma de la escena principal.

Me gustaría saber por que al funcionar el onPress del clip de película, no funcionan los botones que hay dentro de dicho clip de película
  #4 (permalink)  
Antiguo 16/03/2009, 12:54
Avatar de golem44  
Fecha de Ingreso: enero-2009
Ubicación: barcelona
Mensajes: 483
Antigüedad: 8 años, 11 meses
Puntos: 22
Respuesta: Problema botones y clips de película.

Es decir, que tienes un MC con un botón, y dentro de este MC tienes más botones? Creo que no le estás dando la ruta bien. Utiliza_root y parent.
Espero que sea eso?

saludos
  #5 (permalink)  
Antiguo 16/03/2009, 12:57
Avatar de golem44  
Fecha de Ingreso: enero-2009
Ubicación: barcelona
Mensajes: 483
Antigüedad: 8 años, 11 meses
Puntos: 22
Respuesta: Problema botones y clips de película.

es decir:

clipDePelicula.miBoton1.onPress=function(){
trace("boton1");
};
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:26.