Foros del Web » Creando para Internet » Flash y Actionscript »

Problema al Cargar Imagen con LoadClip

Estas en el tema de Problema al Cargar Imagen con LoadClip en el foro de Flash y Actionscript en Foros del Web. Hola, soy nueva en el foro y no se si este tema ya habra salido. He creado una galeria de imagenes dinamica, donde recojo de ...
  #1 (permalink)  
Antiguo 07/04/2008, 11:02
 
Fecha de Ingreso: abril-2008
Mensajes: 3
Antigüedad: 9 años, 8 meses
Puntos: 0
Problema al Cargar Imagen con LoadClip

Hola,

soy nueva en el foro y no se si este tema ya habra salido.
He creado una galeria de imagenes dinamica, donde recojo de un archivo txt el nombre de la carpeta donde esta guardado el archivo y luego lo muestro y redimensio mediante loadclip.
El problema es que en iexplorer se me cargan las imagenes, pero en firefox no.

Os dejo el codigo del object y embed, q no se si será ahi donde esta el problema:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="550" height="400" id="galeria" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="galeria.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" /><embed src="galeria.swf" quality="high" bgcolor="#ffffff" width="550" height="400" name="galeria" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>

Gracias!
  #2 (permalink)  
Antiguo 07/04/2008, 13:05
 
Fecha de Ingreso: noviembre-2005
Ubicación: Huancayo - Perú
Mensajes: 160
Antigüedad: 12 años
Puntos: 7
De acuerdo Re: Problema al Cargar Imagen con LoadClip

Hi, Rachel09,
Mmmmm ahi solo muestras el codigo HTML, deberías mostrar info acerca de tu codigo Actionscript...
Si deseas, te puedo dar una ayuda con ese problemita k tienes en tu codigo ;)
[email protected]

Salu2,
__________________
@PpLucho07
Desarrollador web - Animador Multimedia
[email protected]
  #3 (permalink)  
Antiguo 07/04/2008, 13:33
 
Fecha de Ingreso: abril-2008
Mensajes: 3
Antigüedad: 9 años, 8 meses
Puntos: 0
Re: Problema al Cargar Imagen con LoadClip

Ahi va el codigo AS:


stop();
cargador_lv = new LoadVars();
cargador_lv.load("archivo.txt");
cargador_lv.html = true;
cargador_lv.onLoad = function() {
ruta = "\\"+cargador_lv.museo+"\\";//ruta donde estan las imagenes
titulo = "Galería de "+cargador_lv.museo;
i = 1;
imagen = cargador_lv.museo;
};
i = 1; //contador
ext = ".jpg";
total = "4";//total de imagenes

carga = new LoadVars();
carga.html = true;
carga.onLoad = function(ok) {
if (ok) {
describe = eval("carga.Texto"+i); //carga de la descripción
};
};
carga.load("archivo.txt"); //cargo el texto de la descripcion

var imagen_mcl:MovieClipLoader = new MovieClipLoader();
var mclListener:Object = new Object();
mclListener.onLoadInit = function(target_mc:MovieClip) {//redimensiono la imagen
target_mc._height=295;
target_mc._width=402;
};
imagen_mcl.addListener(mclListener);


imagen_mcl.loadClip(ruta+imagen+i+ext, Contenedor);

//Boton siguiente
sgt_btn.onPress = function() {
if (i<total){
i++;
carga.load("archivo.txt");
imagen_mcl.loadClip(ruta+imagen+i+ext, Contenedor);
}
};

//Boton anterior
ant_btn.onPress = function() {
if (i>1) {
i--;
carga.load("archivo.txt");
imagen_mcl.loadClip(ruta+imagen+i+ext, Contenedor);
}
};
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:59.