Foros del Web » Creando para Internet » Flash y Actionscript »

Problema al cargar peliculas swf

Estas en el tema de Problema al cargar peliculas swf en el foro de Flash y Actionscript en Foros del Web. Saludos a todos. Mirad, tengo una película en flash, que en diferentes momentos carga diferentes películas swf. Me carga la película sin porblema, el problema ...
  #1 (permalink)  
Antiguo 10/12/2003, 13:44
Avatar de Anakin  
Fecha de Ingreso: enero-2003
Ubicación: Girona
Mensajes: 37
Antigüedad: 14 años, 11 meses
Puntos: 0
Exclamación Problema al cargar peliculas swf

Saludos a todos.

Mirad, tengo una película en flash, que en diferentes momentos carga diferentes películas swf.
Me carga la película sin porblema, el problema viene en que no me ejecuta el còdigo actionScript.

Por ejemplo, una de las películas que cargo, es una que contiene los sonidos de fondo y sus controles. Se carga correctamente, pero no reproduce ningun sonido, k éste se inicia con código ActionScript.

I asi todos las otras películas que cargo. Las e abierto independientemente, y funcionan correctamente, pero al ser cargadas por otra película pue sno funcionan.

Ay, se me olvidava, utilizo Macromedia Flash MX 2004 (flash 7.0)

Si me podeis dar una mano, os estaré muy agradecido.

Un abrazo muy grande.
__________________
Anakin Jinn Saban
When the rain marks your road

Última edición por Anakin; 10/12/2003 a las 13:46
  #2 (permalink)  
Antiguo 10/12/2003, 13:59
Avatar de S I D I U S  
Fecha de Ingreso: noviembre-2002
Ubicación: D.F.
Mensajes: 290
Antigüedad: 15 años
Puntos: 0
yo no tengo el flash mx 2004 pero por lo que dices debe de ser un problema de rutas!
__________________
http://www.execomnet.com
  #3 (permalink)  
Antiguo 10/12/2003, 14:40
Avatar de chr_c  
Fecha de Ingreso: junio-2003
Mensajes: 204
Antigüedad: 14 años, 6 meses
Puntos: 0
anakin, fijate como dice sidius las rutas, es decir referite a los objetos con sus rutas absolutas para no tener problemas.

saludos
  #4 (permalink)  
Antiguo 10/12/2003, 15:02
Avatar de Anakin  
Fecha de Ingreso: enero-2003
Ubicación: Girona
Mensajes: 37
Antigüedad: 14 años, 11 meses
Puntos: 0
Pregunta

Holas de nuevo.

Mirad, os cuento.
Él la película principal cargo la película de musica. Wueno, esta se carga en un mc, llamado "muisica".

Poz en la película música, pongo este còdigo:

scL = new Sound();
_root.musica.scL.attachSound("leavetaking");
_root.musica.song_inf = "<b>The Leave Taking</b><br> Per Howard Shore";
_root.musica.ncont = 2;
_root.musica.scL.start(0, 1000);

Creo que tendria que poner la dirección asi, si me equivoco me correjis.

Pos wueno, como podeys ver, en un campo de texto de la película musica, le pongo a traves de ActionScript el nombre de la canción que se reporduce. Lo raro es que el nombre me lo pone sin ningun problema, pero la música sigue sin reporducirse :___(

Que és lo que hago mal ?

Saludos, y muchas gracias por vuestra ayuda.
__________________
Anakin Jinn Saban
When the rain marks your road
  #5 (permalink)  
Antiguo 10/12/2003, 16:44
Avatar de S I D I U S  
Fecha de Ingreso: noviembre-2002
Ubicación: D.F.
Mensajes: 290
Antigüedad: 15 años
Puntos: 0
intenta con: this en lugar de _root.musica
__________________
http://www.execomnet.com
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:43.