Foros del Web » Creando para Internet » Flash y Actionscript »

problema al cargar swf con audio

Estas en el tema de problema al cargar swf con audio en el foro de Flash y Actionscript en Foros del Web. Hola que tal Mi problema es que al cargar un swf (desde un boton) a la pelicula original no me carga el mp3, el swf ...
  #1 (permalink)  
Antiguo 30/05/2003, 16:58
 
Fecha de Ingreso: enero-2003
Mensajes: 12
Antigüedad: 14 años, 10 meses
Puntos: 0
problema al cargar swf con audio

Hola que tal
Mi problema es que al cargar un swf (desde un boton) a la pelicula original no me carga el mp3, el swf lo carga pero sin el audio.
el codigo que le pongo es este.

on (release) {
loadMovie("himno.swf", "window");
}

me falta algo?
ojala me puedan ayudar
Gracias
  #2 (permalink)  
Antiguo 30/05/2003, 19:13
 
Fecha de Ingreso: enero-2003
Mensajes: 12
Antigüedad: 14 años, 10 meses
Puntos: 0
Hola Maltos
Es cierto utilizo _root, pero como lo puedo evitar, estoy utilizando un control de volumen, el mp3 lo he importado y le he puesto linkage. este es el codigo que he puesto.

para inicializar el mp3

s = new Sound();
s.attachSound("misonido");
_root.s.start(0, 999);



y para cntrolar el volumen

onClipEvent (load)
{
top=_y;
left=_x;
right=_x;
bottom=_y+100;
}

onClipEvent(enterFrame)
{
if (arrastrando==true)
{
_root.s.setVolume(100-(_y-top));
}
}
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:20.