Foros del Web » Creando para Internet » Flash y Actionscript »

problema con _getBytesTotal y _getBytesLoaded

Estas en el tema de problema con _getBytesTotal y _getBytesLoaded en el foro de Flash y Actionscript en Foros del Web. Tengo un problema con _getBytesTotal y _getBytesLoaded. Estoy cargando jpeg externos a la pelicula de flash. Y para comprobar el estado de la carga, uso ...
  #1 (permalink)  
Antiguo 03/06/2006, 19:33
 
Fecha de Ingreso: diciembre-2005
Mensajes: 21
Antigüedad: 12 años
Puntos: 0
problema con _getBytesTotal y _getBytesLoaded

Tengo un problema con _getBytesTotal y _getBytesLoaded.

Estoy cargando jpeg externos a la pelicula de flash. Y para comprobar el estado de la carga, uso los métodos _getBytesTotal y _getBytesLoaded, pero resulta que el primer valor que obtengo con _getBytesTotal, es el valor del clip de película sobre el que se carga la "foto.jpg", en este caso de 12Bytes y no el de la foto que se está cargando que es de unos 100Kbytes.

Y al cargar una segunda foto, es cuando aparecen los bytes de la primera.

Porqué va un paso por detrá el método de getBytesTotal();

El código que he usado es el siguiente.

mov01=loadMovie("01.jpg","loadr");
txt01=loadr.getBytesTotal();


¿Qué hago para que sea correcto el valor en cada caso?

Gracias. Un saludo a todos los de este foro.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:32.