Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con UN boton

Estas en el tema de Problema con UN boton en el foro de Flash y Actionscript en Foros del Web. Hola a todos: Me estoy volviendo loco, estoy haciendo un menu para mi web con flash, funcionaba todo bien (todo lo que tenia hecho, faltaba ...
  #1 (permalink)  
Antiguo 16/10/2009, 11:28
 
Fecha de Ingreso: febrero-2005
Mensajes: 51
Antigüedad: 16 años
Puntos: 0
Problema con UN boton

Hola a todos:

Me estoy volviendo loco, estoy haciendo un menu para mi web con flash, funcionaba todo bien (todo lo que tenia hecho, faltaba el contador de visitas y poner los enlaces a los vinculos internos) he añadido un contador de visitas tambien en flash y no se si habra sido por eso pero resulta que el primer boton del menu (El club) ya no funciona.

Cambio la zona activa y sigue igual, lo unico que consigo es que en los extremos laterales del boton si que funcione pero en la zona del texto del boton no. He mirado si el texto era dinamico o estatico, si era seleccionable o no, he borrado y he vuelto a hacer el boton y todo lo que se me ha ocurrido pero nada :S

A ver si alguien me puede ayudar por favor que ya no se que hacer...

Para que veais lo que pasa el archivo swf es este:



(donde pone undefined es el contador pone eso porque no interactua con la pagina php en la que se deberia poner el menu)

Gracias a todos de antemano, un saludo

Última edición por xcvb0; 17/10/2009 a las 08:47
  #2 (permalink)  
Antiguo 16/10/2009, 12:22
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 17 años, 7 meses
Puntos: 406
Respuesta: Problema con UN boton

Hola xcvb0:
Los textos de los botones deben de ir dentro de un campo de texto estático.
Sobre el contador no se sabe como lo haz hecho, porque mejor no subes tu archivo .fla, de ese modo podemos ayudarte mejor.

Espero poderte ser de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 16/10/2009, 12:40
 
Fecha de Ingreso: febrero-2005
Mensajes: 51
Antigüedad: 16 años
Puntos: 0
Respuesta: Problema con UN boton

Cita:
Iniciado por Bandit Ver Mensaje
Hola xcvb0:
Los textos de los botones deben de ir dentro de un campo de texto estático.
Sobre el contador no se sabe como lo haz hecho, porque mejor no subes tu archivo .fla, de ese modo podemos ayudarte mejor.

Espero poderte ser de ayuda.
El texto es estatico al igual que los otros dos botones ("Actualidad" y "la web") si de hecho el boton "el club" funcionaba perfectamente pero ahora no se que pasa que la zona activa no se corresponde :S

Cuelgo el archivo .fla:



Para el contador se utiliza un archivo php con el siguiente codigo (sencillito):

<?php

$archivo = "contador.txt";

$abre = fopen($archivo, "r");

$total = fread($abre, filesize($archivo));

fclose($abre);

$abre = fopen($archivo, "w");

$total = $total + 1;

$grabar = fwrite($abre, $total);

fclose($abre);
?>

Lo que hace es crear un archivo .txt en el que se almacena el numero de visitas.

Al meter el objeto swf en la pagina web hay que meter mas parametros:

<param name="Flashvars" value="counter=<?print($total);?>" />

Y dentro de la etiqueta embed:

Flashvars="counter=<?print($total);?>"

Tengo que añadir que el cogido y la forma de hacer el contador no es mio, lo tengo desde hace por lo menos 4 años ya y no me acuerdo de donde lo saque.

El contador funciona perfectamente (lo he usado mas veces y nunca he tenido ningun problema) y la verdad no se en que momento dejo de funcionar el boton "El club" asi que no se si tiene algo que ver una cosa con la otra :S


Muchas gracias por contestar ;)

Última edición por xcvb0; 17/10/2009 a las 08:47
  #4 (permalink)  
Antiguo 16/10/2009, 19:57
Avatar de mortiprogramador
Colaborador
 
Fecha de Ingreso: septiembre-2009
Ubicación: mortuoria
Mensajes: 3.805
Antigüedad: 11 años, 5 meses
Puntos: 214
Respuesta: Problema con UN boton

Hola
Que as manejas????
y como estas invocando al valor que te llega??
con variable directa o con loadvars??
y bueno, el link que pasaste (donde se ve el undefined) es del swf como tal,
no esta contenido en un html???
revisa eso
nos comentas
saludos
  #5 (permalink)  
Antiguo 17/10/2009, 08:46
 
Fecha de Ingreso: febrero-2005
Mensajes: 51
Antigüedad: 16 años
Puntos: 0
Respuesta: Problema con UN boton

Bueno, ya esta arreglado :) al final lo que he hecho ha sido meter el contador en un clip de pelicula y ya funciono el boton de "El club".

Muchas gracias a todos ;)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:53.