Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con botones

Estas en el tema de Problema con botones en el foro de Flash y Actionscript en Foros del Web. hola a todos Mirar, me he creado un movieclip boton. Que quede claro que no es un boton, es un movie clip, lo que ocurre ...
  #1 (permalink)  
Antiguo 20/05/2005, 06:49
 
Fecha de Ingreso: noviembre-2004
Ubicación: ELche
Mensajes: 153
Antigüedad: 13 años
Puntos: 0
Problema con botones

hola a todos


Mirar, me he creado un movieclip boton. Que quede claro que no es un boton, es un movie clip, lo que ocurre es que por programación lo he hecho completo:

onRollOver = cuando paso por encima cambia de color
onRollOut = onReleaseOutside = cuando salgo del boton o presiono y suelto fuera del boton vuelve a su color original
onPress = el boton se hunde hacia abajo
onRelease = vuelve hacia arriba

bien este es un movie clip y el codigo esta dentro de el movieclip padre, de este modo queda:

movieclip boton -> codigo movie interno
-> movieclip
dentro del MC esta el codigo, y también el movie que hago boton por programación.


Se que es dificil de entender, si teneis dudas avisarme.


bueno si ahora al movieclip boton padre le asigno un onRelease neutraliza al onRelease del boton que esta dentro de el.


Me entendeis ahora


Un saludo

Y gracias por ayudarme

Sergio
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:49.