Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con Botones

Estas en el tema de Problema con Botones en el foro de Flash y Actionscript en Foros del Web. Hola les consulto ya que me preocupa la carga de los botones Flash dentro de mi pagina. Durante muy poco tiempo, antes de que se ...
  #1 (permalink)  
Antiguo 25/07/2007, 21:52
 
Fecha de Ingreso: julio-2007
Mensajes: 57
Antigüedad: 10 años, 4 meses
Puntos: 1
Problema con Botones

Hola les consulto ya que me preocupa la carga de los botones Flash dentro de mi pagina. Durante muy poco tiempo, antes de que se carguen, se ve el fondo de donde se encuentran los botones con fondo BLANCO y no me gusta como se ve estéticamente. Cómo podría solucionarlo? yo solucioné el swf central de la foto haciendo un preloader pero no me parece correcto hacer un preloader para cada boton, espero soluciones que seguro que alguno de uds me la va a poder ofrecer.
Otra consulta es cómo hacer un boton con el estado de "visitado" ya que yo he hecho los mios con "LIBRES", "SOBRE", "PRESIONADO", y me falta el estado de VISITED que quiero que se cambie de color y no lo puedo lograr, espero que me haya explicado bien. Nose si realizar una imagen de cada boton cambiado de color y así ponerlo en cada pagina, pero esto sería algo No práctico.
Muchas gracias por todo y espero su respuesta muy ansioso!!


Esta es la pag: http://www.cincomasdos.com.ar/DEMO/index.html


Juan Pablo Cook
  #2 (permalink)  
Antiguo 26/07/2007, 04:09
 
Fecha de Ingreso: julio-2006
Mensajes: 49
Antigüedad: 11 años, 4 meses
Puntos: 0
Re: Problema con Botones

1º Para que los botones no aparezcan en blanco lo que tienes que hacer es optimizar el peso pues me imagino que seran png-24 bien cargaditos, por eso tardan en salir, en cuanto les bajes el peso seguo que te aparecen de primeras, otra cosa que podrias hacer es un preload, pero con la optimización de peso dudo que no necesites,

2º Para que los botones te salgan visitados tendras que hacer moviclips con 2 fotogramas uno de inactivo y otro de visitado, cuando hallan hecho clik lo mandas al 2, y ya ta
  #3 (permalink)  
Antiguo 26/07/2007, 10:43
 
Fecha de Ingreso: julio-2007
Mensajes: 57
Antigüedad: 10 años, 4 meses
Puntos: 1
Re: Problema con Botones

oK, gracias por contestar pero no se como hacer las cosas.


C4r0nT3: Vos me dijiste: "1º Para que los botones no aparezcan en blanco lo que tienes que hacer es optimizar el peso pues me imagino que seran png-24 bien cargaditos, por eso tardan en salir, en cuanto les bajes el peso seguo que te aparecen de primeras..."

Pero como puedo optimizar el peso? Nose si son png-24, son flash y cosas dibujadas ahi dentro, un boton, MC, etc.

Y por segundo: "2º Para que los botones te salgan visitados tendras que hacer moviclips con 2 fotogramas uno de inactivo y otro de visitado, cuando hallan hecho clik lo mandas al 2, y ya ta". Podrias explicarmelo mejor? porque yo ahora tengo hecho un boton con sus 3 estados y dentro de "SOBRE" tengo un MC con animación. Aca está el .fla para bajarlo si queres verlo: www.cincomasdos.com.ar/HOME.fla.

Muchas gracias y espero tus respuestas...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:32.