Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con botones dentro de un clip

Estas en el tema de Problema con botones dentro de un clip en el foro de Flash y Actionscript en Foros del Web. Hola comunidad!.. la verdad eh buscado bastante para resolver mi problema sin mucho éxito, espero y me puedan ayudar.. Bueno lo que quiero hacer es ...
  #1 (permalink)  
Antiguo 07/05/2008, 19:19
 
Fecha de Ingreso: octubre-2006
Mensajes: 2
Antigüedad: 11 años, 1 mes
Puntos: 0
Problema con botones dentro de un clip

Hola comunidad!.. la verdad eh buscado bastante para resolver mi problema sin mucho éxito, espero y me puedan ayudar..

Bueno lo que quiero hacer es un menú desplegable, que al pasar por encima el mouse me muestre cuatro submenús más y estos submenús me lleven a "x" frame.
ok, lo que he hecho es un movie clip con su respectiva animación mostrando los 4 botones... al movie clip le he puesto el siguiente código:

on(rollOver){this.gotoAndPlay(2);
}
on(rollOut){this.gotoAndPlay(1);
}

Todo parece funcionar bien, el problema es que al desplegar el submenú no me reconoce los botones, es decir, ni haciendo rollover sobre los 4 botones cambia de color, ni nada. bueno espero que me puedan ayudar.. de antemano muchas gracias!..
  #2 (permalink)  
Antiguo 08/05/2008, 14:38
 
Fecha de Ingreso: mayo-2008
Mensajes: 1
Antigüedad: 9 años, 7 meses
Puntos: 0
Re: Problema con botones dentro de un clip

Creo tener el mismo problema:
Un Mclip que al hacer rollOver abre un menú con botones. Los botones redirigen a la URL señalada, pero no puedo ver su estado Over (o sobre) cuando paso por encima de ellos....

alguna solución?

Gracias desde ya,
S0fI
  #3 (permalink)  
Antiguo 08/05/2008, 17:17
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: Problema con botones dentro de un clip

Hola keizyu:
Bienvenido al Foro.
Si tu pones el códigos al MC, los botones internos dejarán de funcionar.
Lo que tienes que hacer es colocar un botón en la capa 1 frame 1 del MC y allí colocar tu código.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #4 (permalink)  
Antiguo 08/05/2008, 17:21
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: Problema con botones dentro de un clip

Hola sofisofi:
Bienvenido al Foro.
Como supongo que el código on(rollOver); lo haz puesto al MC, está sucediendo lo mismo que a keizyu, haz como explico en el post anterior.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:50.