Foros del Web » Creando para Internet » Flash y Actionscript »

problema con botones dentro d una animacion

Estas en el tema de problema con botones dentro d una animacion en el foro de Flash y Actionscript en Foros del Web. Hola Buenas a todos, tengo un problema, yo cree una especie de intro en la cual hay un logo en el centro que simula latido, ...
  #1 (permalink)  
Antiguo 04/04/2007, 06:57
 
Fecha de Ingreso: marzo-2007
Mensajes: 91
Antigüedad: 10 años, 9 meses
Puntos: 0
Pregunta problema con botones dentro d una animacion

Hola Buenas a todos, tengo un problema, yo cree una especie de intro en la cual hay un logo en el centro que simula latido, luego desaparece con un alpha y aparece la pagina real, yo quiero que los botones aparezcan cuando el latido desaparece, entonces lo que hice fue agregar esos botones en el ultimo fotograma de la animacion, es decir cuando aparece la pagina real, el problema es que a esos botones le digo que vallan a la escena x, pero vuleven a la animacion del latido, no se como solucionarlo ni lo que esta bien o mal....espero haberme explicado bien, tengo que solucionar eto cuanto antes, les agradezco desde ya....muchas gracias y un saludo a todos
  #2 (permalink)  
Antiguo 04/04/2007, 10:28
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: problema con botones dentro d una animacion

Hola kroli:
Si tu película está hecha con varias escenas, lo primero que tendrás que hacer es colocar una etiqueta en el primer frame de cada escena.
Código para el botón:
on(release){
gotoAndPlay("etiqueta");
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 05/04/2007, 05:22
 
Fecha de Ingreso: marzo-2007
Mensajes: 91
Antigüedad: 10 años, 9 meses
Puntos: 0
Re: problema con botones dentro d una animacion

Hola Bandit, probe con lo que me dijiste pero no hace nada ahora...seguire averiguando a ver si lo puedo solucionar, el problema es que los botones estan dentro de la animacion porque lo hice sin que este dentro y funcionaba, el problema es que no tienen que aparecer los botones al principio, si lo puedo hacer de otra manera que sepas te lo agradeceria, muchas gracias por tu atencion, buena suerte
  #4 (permalink)  
Antiguo 05/04/2007, 09:59
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: problema con botones dentro d una animacion

Si la animación y los botones están dentro de un MC, simplemente en el código adiciona a la acción: _root.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 27/10/2007, 01:19
 
Fecha de Ingreso: octubre-2007
Mensajes: 1
Antigüedad: 10 años, 1 mes
Puntos: 0
Re: problema con botones dentro d una animacion

es sencillo le das en vez de un actions.. un behaviors goto y especificas la escena
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:27.