Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con carga

Estas en el tema de Problema con carga en el foro de Flash y Actionscript en Foros del Web. Buenas, tengo una película flash en la cual cargo una pelicula llamada "musica.swf", donde en el primer y único frame pongo: mimusica=new Sound(); mimusica.attachSound("musica"); mimusica.start(0,10000); ...
  #1 (permalink)  
Antiguo 20/11/2004, 06:31
Avatar de javiermil  
Fecha de Ingreso: agosto-2004
Mensajes: 509
Antigüedad: 13 años, 3 meses
Puntos: 2
Problema con carga

Buenas, tengo una película flash en la cual cargo una pelicula llamada "musica.swf", donde en el primer y único frame pongo:

mimusica=new Sound();
mimusica.attachSound("musica");
mimusica.start(0,10000);
mimusica.setVolume(200);
stop();

El identificador está relacionado en la biblioteca asi que por eso no es.
Me funciona bien si la ejecuto sola, pero una vez llamada desde el otro movie no se escucha nada.A ver si encontrais soluciones porque llevo horas y no lo saco jejeje.Saludos
  #2 (permalink)  
Antiguo 20/11/2004, 09:36
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola javiermil:
Eso sucede porque en la biblioteca de la nueva película de donde llamas musica.swf, no esta el sonido, porque estás attachando un sonido vinculado de la biblioteca de musica.swf, importar a la biblioteca de la nueva película el sonido.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 20/11/2004, 12:12
Avatar de javiermil  
Fecha de Ingreso: agosto-2004
Mensajes: 509
Antigüedad: 13 años, 3 meses
Puntos: 2
Buenas, mira son dos peliculas una que se llama principal.swf que llama a otra que se llama musica.swf, en musica swf es dobde attaco al sonido y donde tengo en la biblioteca el sonido, que tengo que ponerlo en pricipal.swf? Un saludo y gracias
  #4 (permalink)  
Antiguo 20/11/2004, 13:08
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola javiermil:
Ya te dije que en la película principal no tienes el sonido, si no en la biblioteca de musica.fla, por eso no te carga el sonido, solamente tienes que importar a la biblioteca de la principal el sonido.

Espero que ahora esté más claro.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 20/11/2004, 13:12
Avatar de javiermil  
Fecha de Ingreso: agosto-2004
Mensajes: 509
Antigüedad: 13 años, 3 meses
Puntos: 2
muchas gracias. Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:44.