Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con carga de SWF

Estas en el tema de Problema con carga de SWF en el foro de Flash y Actionscript en Foros del Web. Hola. Tengo un problema: Tengo una pelicula madre que llama a otras peliculitas.swf en una de las peliculitas .swf hice un efecto de scroll vertical ...
  #1 (permalink)  
Antiguo 03/03/2006, 11:30
 
Fecha de Ingreso: marzo-2002
Ubicación: Santiago
Mensajes: 170
Antigüedad: 15 años, 9 meses
Puntos: 0
Problema con carga de SWF

Hola.
Tengo un problema:
Tengo una pelicula madre que llama a otras peliculitas.swf
en una de las peliculitas .swf hice un efecto de scroll vertical del tipo:

_root.slider._y = _root.slider._y-3;
//when mouse moves Up, navigation panel moves Down
if ((_xmouse>11) && (_xmouse<315) && (_ymouse>40) && (_ymouse<150)) {
_root.slider._y = _root.slider._y+10;
}
//when mouse moves Down, navigation panel moves Up
if ((_xmouse>11) && (_xmouse<315) && (_ymouse>180) && (_ymouse<288)) {
_root.slider._y = _root.slider._y-10;
}
//when navigation panel reaches it's maximum y-value it resets itself
if (_root.slider._y>40) {
_root.slider._y = 40;
}
if (_root.slider._y<-725) {
_root.slider._y = 782;
}

Si pruebo la peliculita .swf sola funciona el efecto perfecto...
PERO:
Cuando lo publico en la web y la película madre llama a la peliculita, aparece, pero no funciona el efecto.

Que puede estar pasando??????

Gracias.-
  #2 (permalink)  
Antiguo 03/03/2006, 11:41
Avatar de lucasiramos  
Fecha de Ingreso: agosto-2004
Ubicación: Santa Rosa, La Pampa, Argentina
Mensajes: 1.484
Antigüedad: 13 años, 4 meses
Puntos: 13
Cita:
Iniciado por procer
Hola.
Tengo un problema:
Tengo una pelicula madre que llama a otras peliculitas.swf
en una de las peliculitas .swf hice un efecto de scroll vertical del tipo:

_root.slider._y = _root.slider._y-3;
//when mouse moves Up, navigation panel moves Down
if ((_xmouse>11) && (_xmouse<315) && (_ymouse>40) && (_ymouse<150)) {
_root.slider._y = _root.slider._y+10;
}
//when mouse moves Down, navigation panel moves Up
if ((_xmouse>11) && (_xmouse<315) && (_ymouse>180) && (_ymouse<288)) {
_root.slider._y = _root.slider._y-10;
}
//when navigation panel reaches it's maximum y-value it resets itself
if (_root.slider._y>40) {
_root.slider._y = 40;
}
if (_root.slider._y<-725) {
_root.slider._y = 782;
}

Si pruebo la peliculita .swf sola funciona el efecto perfecto...
PERO:
Cuando lo publico en la web y la película madre llama a la peliculita, aparece, pero no funciona el efecto.

Que puede estar pasando??????

Gracias.-
Hola! Estas teniendo un problema con las peliculas madre/hija. Proba reemplazando los _root.slider por this.slider. Seguramente es eso.

Cualquier cosita postea
Espero te sirva.
Saludos. Lucas
__________________
No sign...
  #3 (permalink)  
Antiguo 03/03/2006, 12:22
 
Fecha de Ingreso: marzo-2002
Ubicación: Santiago
Mensajes: 170
Antigüedad: 15 años, 9 meses
Puntos: 0
Eres un GENIO
Mil Gracias.-!!!!!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:40.