Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con codigo Actionscript

Estas en el tema de Problema con codigo Actionscript en el foro de Flash y Actionscript en Foros del Web. Tengo un problemita, hay un script q habia usado para Flash7 que en flash8 no me esta funcionando: Código: i = 0; while (Number(i)<>50) { ...
  #1 (permalink)  
Antiguo 06/05/2007, 21:28
 
Fecha de Ingreso: septiembre-2003
Mensajes: 92
Antigüedad: 14 años, 2 meses
Puntos: 0
Problema con codigo Actionscript

Tengo un problemita, hay un script q habia usado para Flash7 que en flash8 no me esta funcionando:
Código:
i = 0;
while (Number(i)<>50) {
	j = 1+random(3);
	duplicateMovieClip("snow" add j, "snowafter" add i, i);
	i = Number(i)+5;
}
Me esta tirando este error:

Código:
**Error** Symbol=Symbol 77, layer=Layer 1, frame=1:Line 4: ')' or ',' expected
     	duplicateMovieClip("snow" add j, "snowafter" add i, i);

**Error** Symbol=Symbol 77, layer=Layer 1, frame=1:Line 6: Unexpected '}' encountered
     }

Total ActionScript Errors: 2 	 Reported Errors: 2
Alguien me puede dar una mano ? por que necesito exportarlo en flash 8 y se me esta complicando.

Gracias y Saludos!!
  #2 (permalink)  
Antiguo 06/05/2007, 21:32
Avatar de PabloSutra  
Fecha de Ingreso: octubre-2006
Ubicación: Guadalajara, México
Mensajes: 222
Antigüedad: 11 años, 2 meses
Puntos: 0
Re: Problema con codigo Actionscript

trata de cambiar los "add" por el signo de "+"
Espero te sirva
SALUD!!!
  #3 (permalink)  
Antiguo 08/05/2007, 22:57
 
Fecha de Ingreso: septiembre-2003
Mensajes: 92
Antigüedad: 14 años, 2 meses
Puntos: 0
Re: Problema con codigo Actionscript

Genial, era eso nomas. Muchas Gracias!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:56.