Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con Codigo de preloader

Estas en el tema de Problema con Codigo de preloader en el foro de Flash y Actionscript en Foros del Web. Buen Día, hice un preloader para una página web que a su vez esta compuesta por 5 escenas, el preloader lo hice en la primera ...
  #1 (permalink)  
Antiguo 14/01/2010, 11:55
 
Fecha de Ingreso: enero-2010
Mensajes: 3
Antigüedad: 11 años
Puntos: 0
Pregunta Problema con Codigo de preloader

Buen Día, hice un preloader para una página web que a su vez esta compuesta por 5 escenas, el preloader lo hice en la primera escena, en el primer fotograma y según especificaciones de este video:

http://www.youtube.com/watch?v=EyhewXRUVHs&feature=related

Todo bien hasta que probé la pelicula y me salia el error:

TypeError: Error #1009: No se puede acceder a una propiedad o a un método de una referencia a un objeto nulo.
at Portafolio_fla::MainTimeline/lodeando()

he revisado muchas veces el código y los nombres de instancia pero me sigue saliendo el error.
Este es el código:


stop();

addEventListener(Event.ENTER_FRAME,lodeando);

function lodeando(event:Event):void
{
var bytesTotales = stage.loaderInfo.bytesTotal ;
var bytesCargados = stage.loaderInfo.bytesLoaded ;
var porcentaje = Math.round(bytesCargados * 100 / bytesTotales);

TextoPorcentaje.text = porcentaje + "% Cargados";
cargaanimada_mc.gotoAndStop(porcentaje);

if (bytesCargados == bytesTotales)
{
removeEventListener(Event.ENTER_FRAME,lodeando);
gotoAndPlay(3);
TextoPorcentaje.text = "";
removeChild(TextoPorcentaje);
removeChild(cargaanimada_mc);
}
}




Ojalá me puedan ayudar, Muchas Gracias
  #2 (permalink)  
Antiguo 14/01/2010, 12:14
 
Fecha de Ingreso: diciembre-2009
Mensajes: 186
Antigüedad: 11 años, 1 mes
Puntos: 5
Respuesta: Problema con Codigo de preloader

Hola jcjimenez

El error que te salta es provocado por que has escrito mal alguno de los nombres o propiedades de los objetos o porque no existen, es decir, no encuentra uno o varios objetos o propiedades.

Para que funcione el ejemplo del video tienes que crear todos los elementos que se crean en el y ponerles los mismos nombres.

Mirando un poco el código hay un nombre de objeto que no es igual que el del video: has puesto cargaanimada_mc en vez de carganimada_mc.

Revisa otra vez el código y comprueba que los nombres y propìedades de los elementos del fotorama están bien escritos.

Luego nos cuentas.
  #3 (permalink)  
Antiguo 14/01/2010, 14:45
Avatar de DarkskullDA  
Fecha de Ingreso: julio-2006
Mensajes: 698
Antigüedad: 14 años, 6 meses
Puntos: 13
Respuesta: Problema con Codigo de preloader

com ote dice darkwater.. es debido a q no encuentra el objeto..

recuerda q ese codigo debe ir en el mismo frame que el mc....
esperemos lo peudas resolver..
si no leete este http://muelalab.com/blog/?p=32

suerte..
__________________
Curso Desarrollo De Aplicaciones IFrame Para Facebook Conoce la Graph Api, Javascript/PHP SDK, Dialogos, Pestañas, entre otros.
  #4 (permalink)  
Antiguo 14/01/2010, 15:11
 
Fecha de Ingreso: enero-2010
Mensajes: 3
Antigüedad: 11 años
Puntos: 0
Respuesta: Problema con Codigo de preloader

Gracias por responder, ya encontre cual era el problema, la capa donde se encontraba la precarga sólo estaba en el primer fotograma, lo que hice fue que la capa estuviera visible durante toda la animación y listo.
Todo estaba bien escrito en el codigo y en los nombres de instancia.

Etiquetas: preloader
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:51.