Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con CreateEmptyMovieClip

Estas en el tema de Problema con CreateEmptyMovieClip en el foro de Flash y Actionscript en Foros del Web. Tengo un problema con esta función. Tengo una película a la que necesito insertarle otro archivo swf y para ello hago lo siguiente. Código: img_full ...
  #1 (permalink)  
Antiguo 22/03/2005, 18:50
Avatar de FuLaNo_  
Fecha de Ingreso: mayo-2003
Ubicación: Don Torcuato, Buenos Aires, Argentina
Mensajes: 1.250
Antigüedad: 14 años, 6 meses
Puntos: 2
Problema con CreateEmptyMovieClip

Tengo un problema con esta función.

Tengo una película a la que necesito insertarle otro archivo swf y para ello hago lo siguiente.

Código:
img_full = "http://www.midominio.com/flash/" + imgX;
createEmptyMovieClip("myimg",1);
myimg._x= Ximg;
myimg._y= Yimg;
myimg.loadMovie(img_full, 1);
Todo funciona perfecto, solamente que el archivo que inserto queda "por encima" de todos las capas de la película principal, hay alguna forma de que la película externa se inserte por debajo de X capa? (el código que inserta la película esta en la Capa en donde debería ir, pero se crea sobre las demás)

Si alguien tiene algún consejo...
__________________
I Love Programming...
  #2 (permalink)  
Antiguo 23/03/2005, 03:41
 
Fecha de Ingreso: marzo-2005
Ubicación: Barcelona
Mensajes: 71
Antigüedad: 12 años, 8 meses
Puntos: 1
yo, como no encontré manera de poder hacerlo, me acostrumbré a poner manualmente el clip vacío en la capa que sea y a duplicarlo, cambiarlo de sitio, load y unload movie, .... todo dinámicamente
__________________
MZ
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:44.