Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con currentframe-1

Estas en el tema de Problema con currentframe-1 en el foro de Flash y Actionscript en Foros del Web. Hola, mi problema es el siguiente. tengo una pelicula que avanza y se recoge con currentframe-1 y funciona bien.Lo único es que cuando quiero meter ...
  #1 (permalink)  
Antiguo 09/06/2008, 03:58
 
Fecha de Ingreso: junio-2008
Mensajes: 1
Antigüedad: 9 años, 6 meses
Puntos: 0
Problema con currentframe-1

Hola, mi problema es el siguiente.
tengo una pelicula que avanza y se recoge con currentframe-1 y funciona bien.Lo único es que cuando quiero meter un botón dentro de cada sección, no me lo reconoce. Al pasar el puntero no hace nada.
No se me ocurre nada si sabeis como conseguirlo y podeis ayudarme os lo agradecería.

El archivo lo podeis descargar aqui:

http://www.rgapublicidad.net/download/current.rar
  #2 (permalink)  
Antiguo 09/06/2008, 05:32
Avatar de sirguy  
Fecha de Ingreso: septiembre-2006
Ubicación: Mallorca
Mensajes: 959
Antigüedad: 11 años, 2 meses
Puntos: 12
Respuesta: Problema con currentframe-1

El fallo será que el clip que sirve de contenedor al botón funciona como botón, entra en el clip 3, quita el stop del primer frame de manera que no necesites pulsar para que se accione. Ahora vete a la principal y quítale al clip toda la línea del on(release)... y verás que ebotón funciona. La solución es poner un botón invisible dentro del clip sobre los números, simplemente le pones un _root a las rutas y funcionará igual y podrás usar todos los botones que vayan dentro de estos clips.
__________________
Chanante!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:36.