Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con enabled de botones

Estas en el tema de Problema con enabled de botones en el foro de Flash y Actionscript en Foros del Web. Cita: function mifuncion() { for (var i = 1; i<5; i++) { _parent['btn'+i].enabled = false;/////esta linea } } Bueno viendo el codigo anterior se ve ...
  #1 (permalink)  
Antiguo 13/09/2006, 19:10
Avatar de Nova  
Fecha de Ingreso: enero-2003
Ubicación: Hyo
Mensajes: 832
Antigüedad: 14 años, 10 meses
Puntos: 1
Problema con enabled de botones

Cita:
function mifuncion() {
for (var i = 1; i<5; i++) {
_parent['btn'+i].enabled = false;/////esta linea
}
}
Bueno viendo el codigo anterior se ve que se desabilita los botones de un nivel superior. Pero cuando quiero desabilitar con el mismo codigo los botones que estan en el mismo nivel ya no funciona.
Cita:
function mifuncion() {
for (var i = 1; i<5; i++) {
['btn'+i].enabled = false;/////asi ya no funciona!!!!!!!!!!
}
}
porfa ayudenme, gracias
__________________
http://about.me/jemano
  #2 (permalink)  
Antiguo 13/09/2006, 23:27
 
Fecha de Ingreso: enero-2005
Ubicación: culiacan, sinaloa, mexico
Mensajes: 97
Antigüedad: 12 años, 11 meses
Puntos: 0
function mifuncion() {
for (var i = 1; i<5; i++) {
this['btn'+i].enabled = false;
/////asi ya no funciona!!!!!!!!!!
}
}
mifuncion();
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:55.