Foros del Web » Creando para Internet » Flash y Actionscript »

problema con enlace

Estas en el tema de problema con enlace en el foro de Flash y Actionscript en Foros del Web. Hola a to2!! Tengo un problemilla con un enlace. Se trata de una palabra que sale de un punto de la pantalla y va hasta ...
  #1 (permalink)  
Antiguo 11/07/2003, 05:14
 
Fecha de Ingreso: febrero-2003
Mensajes: 15
Antigüedad: 14 años, 10 meses
Puntos: 0
problema con enlace

Hola a to2!!
Tengo un problemilla con un enlace. Se trata de una palabra que sale de un punto de la pantalla y va hasta otro punto donde ya permanece inmobil. El movimiento lo hace correctamente y en el fotograma en el que se queda fijo lo he convertido en símbolo de película y en acciones le he puesto algo así:

on (press) {
getURL("[email protected]");
}

Al verificar si el código es correcto me dice que los eventos on(press) sólo se pueden asignar a botones y no a símbolos de película. Pero el caso es que hace un tiempo hice algo similar y funcionó correctamente. Alguien sabe por k?? o donde está mi error??

Gracias por adelantado!!
  #2 (permalink)  
Antiguo 11/07/2003, 11:23
Avatar de Prince  
Fecha de Ingreso: mayo-2003
Ubicación: DF
Mensajes: 574
Antigüedad: 14 años, 7 meses
Puntos: 1
Eso de los eventos tipo Botón en un clip de Película solo se puede a partir de esta versión MX, así que si hiciste la animación en MX no hay ningún problema. Recuerda que las direcciones URL tienen que ir completas y como es dirección, pues va sin arroba -(@) "http://www.loksea.com".

Espero que esto te ayude.
__________________
- P R I N C E -
  #3 (permalink)  
Antiguo 11/07/2003, 11:23
Avatar de juwe  
Fecha de Ingreso: abril-2001
Ubicación: Guadalupe Inn
Mensajes: 622
Antigüedad: 16 años, 7 meses
Puntos: 0
El único modo de asignar eventos de botón a una mc es así:
Código:
tu_mc.onRelease = function() {
   getURL (bla bla bla)
}
Y este código se pone en un frame, no en la mc, y esta sintaxis sólo funciona para FlashMX.
En Flash 5 lo más cercano a esto puede ser:
Código:
onClipEvent (MouseDown) {
   getURL (bla bla bla);
}
Saludos desde México.
__________________
blog.juwestudio
  #4 (permalink)  
Antiguo 12/07/2003, 06:58
 
Fecha de Ingreso: febrero-2003
Mensajes: 15
Antigüedad: 14 años, 10 meses
Puntos: 0
sobre la version...

Tema solucionado!!
Como podreis imaginar soy muy nuevo en esto, me he dado cuenta que en la opcion Archivo-configuracion de publicacion-Flash. Tenia la opcion Flash 5 por lo k no me pillaba lo del on(press) en la mc, sin embargo cambiandolo a flash 6 ya esta todo como antes.
Muchas gracias por todo....
Salu2 para to2!!

Última edición por pinguin; 12/07/2003 a las 13:59
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:13.