Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con Flash

Estas en el tema de Problema con Flash en el foro de Flash y Actionscript en Foros del Web. Hola amigos, estoy terminando una web en flash y me he encontrado con un gran problema, es algo lioso espero explicarlo bien: Tengo una pelicula ...
  #1 (permalink)  
Antiguo 10/07/2007, 13:22
Avatar de adexedl  
Fecha de Ingreso: julio-2005
Mensajes: 326
Antigüedad: 12 años, 5 meses
Puntos: 2
Problema con Flash

Hola amigos, estoy terminando una web en flash y me he encontrado con un gran problema, es algo lioso espero explicarlo bien:

Tengo una pelicula ya montada en varios clips, pero hay uno de ellos que no se me ejecuta. Mi pelicula tiene este aspecto

ESCENA1/PELICULA/PORTFOLIO/WEBSITES/BOTON todos son un clip dentro de otro. Ahora el problema, tengo un boton dentro del clip BOTON y lo que quiero es que al pulsarlo vaya y se ejecute en el fotograma 2 del clip WEBSITES. Ufff espero haberlo explicado bien. Yo lo estoy intendo de la siguiente forma pero no funciona

on (release) {
_root.websites.gotoAndStop("2");
}


Muchas gracias de antemano
  #2 (permalink)  
Antiguo 10/07/2007, 13:45
Avatar de Turdo  
Fecha de Ingreso: julio-2005
Ubicación: .:Guadalajara:.
Mensajes: 398
Antigüedad: 12 años, 4 meses
Puntos: 23
Re: Problema con Flash

Hola amigo!!

Tienes que poner toda la ruta:
_root.PELICULA/PORTFOLIO/WEBSITES.gotoAndStop("2");

o poner this.gotoAndStop("2");
  #3 (permalink)  
Antiguo 10/07/2007, 14:30
Avatar de adexedl  
Fecha de Ingreso: julio-2005
Mensajes: 326
Antigüedad: 12 años, 5 meses
Puntos: 2
Re: Problema con Flash

Hola Turdo, no funciona tampoco de esa forma. Saludos
  #4 (permalink)  
Antiguo 10/07/2007, 14:41
 
Fecha de Ingreso: septiembre-2006
Mensajes: 1.193
Antigüedad: 11 años, 2 meses
Puntos: 30
Re: Problema con Flash

puedes poner esto dentro de tu boton:

Código:
_root.PELICULA.PORTFOLIO.WEBSITES.gotoAndStop(2);
o esto



Código:
_parent.gotoAndStop(2)
recuerda que si vas a poner comillas dentro del gotoAndStop("aqui"); es por que nombraste en la ventana de propiedades al fotograma. en este caso supongo que no lo hiciste y se las quite, y gotoAndStop() y gotoAndPlay() son diferentes ok.
  #5 (permalink)  
Antiguo 10/07/2007, 16:42
Avatar de adexedl  
Fecha de Ingreso: julio-2005
Mensajes: 326
Antigüedad: 12 años, 5 meses
Puntos: 2
Re: Problema con Flash

Ok Rizzo, justo lo que necesitaba muchas gracias.

Lo que ahora tengo un problema minimo, hay clips dentro de este clip (del websites) que no c me ejecutan. Son simples alfas que estan dentro de un movieclip ¿Sabes a que puede ser?

Muchas gracias y un saludo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:10.