Foros del Web » Creando para Internet » Flash y Actionscript »

problema con funcion

Estas en el tema de problema con funcion en el foro de Flash y Actionscript en Foros del Web. Buenas , espero puedan ayudarme porque ya no se por donde seguir. Estoy intentando hacer un pase de fotos cargadas dinamicamente, en las que me ...
  #1 (permalink)  
Antiguo 26/03/2009, 13:23
 
Fecha de Ingreso: diciembre-2006
Mensajes: 10
Antigüedad: 11 años
Puntos: 0
problema con funcion

Buenas , espero puedan ayudarme porque ya no se por donde seguir.

Estoy intentando hacer un pase de fotos cargadas dinamicamente, en las que me salen cada vez 3 fotos una centrada (actF), otra a la izquierda de esta(prevF) y otra a la derecha (nextF). Cuando se ejecuta un movimiento en las fotos la del medio ejecuta un efecto de visualización y a las fotoprev y fotonext, les quiero bajar el alpha para que destaque la fotoactual. La cuestión es que si quiero bajarle el alpha a la foto numero 5 por ejemplo, poniendo esto directamente :

_level0.lienzo_fotos.bajo_0_5._alpha = 30;

se ejecuta el alpha y esa foto esta con ese alpha, pero si por ejemplo hago esto para luego intentar hacer una función que vaya cambiando dependiendo de cual sea la foto siguiente y la anterior no me funciona, y no se el por qué?

var prueba = "_level0.lienzo_fotos.bajo_0_"+(4+1);
prueba._alpha = 30;

Alguien podría decirme que estoy haciendo mal y como lo puedo hacer .

Muchas gracias, por vuestro tiempo.
  #2 (permalink)  
Antiguo 26/03/2009, 17:14
 
Fecha de Ingreso: marzo-2009
Mensajes: 13
Antigüedad: 8 años, 8 meses
Puntos: 1
Respuesta: problema con funcion

Pues simplemente estas intentando cambiar el alpha a una variable de tipo cadena xD.

Código:
var prueba = "_level0.lienzo_fotos.bajo_0_"+(4+1);
prueba es una variable a la que le das ese valor, no hace referencia a ningun clip ni a nada mas.

La forma correcta seria esta:

Código:
_root["_level0.lienzo_fotos.bajo_0_"+(4+1)]._alpha = 100;
Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:00.