Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con Galeria de imagenes

Estas en el tema de Problema con Galeria de imagenes en el foro de Flash y Actionscript en Foros del Web. Hola, soy nuevo en el foro. Necesito resolver un tema que me hace dias me esta volviendo loco: Estoy haciendo una galeria de imágenes, redacte ...
  #1 (permalink)  
Antiguo 06/10/2008, 23:07
 
Fecha de Ingreso: octubre-2008
Mensajes: 2
Antigüedad: 9 años, 2 meses
Puntos: 0
Problema con Galeria de imagenes

Hola, soy nuevo en el foro. Necesito resolver un tema que me hace dias me esta volviendo loco:
Estoy haciendo una galeria de imágenes, redacte el codigo y funciona perfecto cuando el boton que lo ejecuta esta en el root, pero si lo pongo dentro de un MC me lleva al root, pero la galeria no carga las imagenes. Aca dejo el codigo...

on (release) {
_root.gotoAndStop("travel");

this.obra.folder.text='europa2006';
this.obra.num_foto.text='1';
this.obra.max_num.text='15';
loadMovie("images/" + this.obra.folder.text + "/foto_"+ this.obra.num_foto.text+".jpg", _root.obra.ubicacion);


}

Supongo que solo me debe faltar algun comando,
ya que hasta el _root.gotoAndStop("travel"); funciona y luego no carga la galeria


Por favor ayuda!
gracias.
  #2 (permalink)  
Antiguo 07/10/2008, 06:50
cas
 
Fecha de Ingreso: diciembre-2004
Ubicación: barcelona
Mensajes: 54
Antigüedad: 13 años
Puntos: 0
Respuesta: Problema con Galeria de imagenes

on (release) {
_root.gotoAndStop("travel");

No sé si he entendido bien la ruta pero creo que tendría que ser así
this._parent.obra.folder.text='europa2006';
this._parent.obra.num_foto.text='1';
this._parent. obra.max_num.text='15';
loadMovie("images/" + this._parent.obra.folder.text + "/foto_"+ this._parent .obra.num_foto.text+".jpg", _root.obra.ubicacion);

}
  #3 (permalink)  
Antiguo 07/10/2008, 07:48
Avatar de Lynxcraft  
Fecha de Ingreso: noviembre-2007
Ubicación: yecla murcia
Mensajes: 1.346
Antigüedad: 10 años
Puntos: 51
Respuesta: Problema con Galeria de imagenes

bueno para mi es que debe ser así XDXD



Código PHP:
on (release) {
_root.gotoAndStop("travel");
var 
v_folder:String 'europa2006';
var 
v_num_foto:Number 1;
var 
v_max_num:Number 15;

_root.obra.folder.text v_folder;
_root.obra.num_foto.text v_num_foto;
_root.obra.max_num.text v_max_num;
loadMovie("images/"+v_folder+"/foto_"+v_num_foto+".jpg"_root.obra.ubicacion);

también tienes que tener cuidado con los espacios a la hora de poner + por que si no te da error
suerte XD
__________________
Sobran las ideas cuando faltan ganas de trabajar en ellas
Lynxcraft
  #4 (permalink)  
Antiguo 07/10/2008, 09:46
 
Fecha de Ingreso: octubre-2008
Mensajes: 2
Antigüedad: 9 años, 2 meses
Puntos: 0
Respuesta: Problema con Galeria de imagenes

Hola chicos, gracias por las respuestas, pero sigue sin funcionar.

dejo el link de la web:
http://www.kidart.com.ar/new/kidart.html es en la seccion "travel" y pegue los 2 botones ("europatour2006")
AMBOS con el mismo codigo, uno funciona (esta en la linea de tiempo principal)
y el otro no funciona (esta dentro de un movie clip para poder hacer el scroll con los botones).


Alguna otra idea de que puede faltarle al codigo?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:59.